I am learning about NGS analysis and im currently learning about QCing and removing adaptors.

I am working on SRR1972920_1.fastq file.

When running fastqc tool on that file, adapter contamination is present in the form of Nextera Transposase adapters.

Searching for that adapter sequence via google the sequence for at the 3' end to be removed is TCGTCGGCAGCGTCAGATGTGTATAAGAGACAG (obtained via illumina adapter sequence-Nature).

Running a very basic cutadapt command line to remove the adapter

cutadapt -a TCGTCGGCAGCGTCAGATGTGTATAAGAGACAG -o <any output name> <my input file> 

After running the fastqc tool again on the new output file from cutadapt, it seems nothing changed and the contamination still present.

However, when running the same command above but changing the sequence to CTGTCTCTTATA, which is the sequence of transposase adaptors according to fastqc tool adapters_list.txt file all is good after running fastqc tool on the file

cutadapt -a CTGTCTCTTATA  -o <any output name> <my input file> 

Now, why this is happening? which Nextera transposase sequence is the correct? or am I doing something wrong?


3 Answers 3


The adapter sequence you have googled is the sequence on the adapter primer. This works when you want to remove primer-dimers.

With transposase adapters or ATAC seq, you have very short fragments and you sequence into the adapter. So what you is sequenced is actually the reverse complement. See below image from trimmomatic manual

enter image description here

So if you look at what worked, and the sequence you googled, they are reverse complement of one another.

You can also see this in the NexteraPE-PE.fa, Trans1 and Trans1_rc @Haci recommended:

more NexteraPE-PE.fa 

To answer your question, if most of your fragments are short, and there's not a lot of primer dimers, then yes you are doing the right thing.

  • $\begingroup$ Ok, im getting confused already :). What do you mean by adapter primer? $\endgroup$
    – Skepto18
    Commented Oct 31, 2019 at 23:04
  • $\begingroup$ I meant the sequence of the adapter itself. Referring to the image I have in the post, adapter would be in the blue part. If you have short fragments that exceed sequencing length, you will sequence the adaptor on the right side(red). However the sequence you get in the fastq is the reverse complement. $\endgroup$
    – StupidWolf
    Commented Nov 4, 2019 at 9:05

I cannot quite help(*) on the problem you are having with cutadapt but can point you out to Trimmomatic, for which the developers have been granted permission to distribute Illumina adapter sequences.

If you download Trimmomatic, you will see a bunch of Illumina adapter sequence files in the /trimmomatic-0.39/adapters/ folder. Actually the adapter sequence you have found via googling is listed in the file NexteraPE-PE.fa.

* Regarding the undesired output with cutadapt, you were probably removing one of the multiple Nextra adapter options but not the exact one used in your library preparation step. You won't have to worry about finding the exact adapter sequence used in the library prep step when using Trimmomatic as it scans for the presence of all possible adapter sequences.

  • $\begingroup$ Note that Trimmomatic has a trimming step that specifically looks for (and trims out) adapter read-through. $\endgroup$
    – gringer
    Commented Oct 31, 2019 at 21:42
  • $\begingroup$ @Haci could you please elaborate how to let trimmomatic scan for the presence of all possible adapter sequences? I have just read the trimmomatic manual and I dont think I came across such option. Also I read on a blog post confirming what you saying "I know that a lot of people run Trimmomatic without checking which types of adaptors they actually have in the data and it often works. " $\endgroup$
    – Skepto18
    Commented Dec 9, 2019 at 0:18
  • 1
    $\begingroup$ What I meant was the adapters and their reverse complements, PCR primers, ... are all included in the "adapter files" in the "adapters" folder. One should know at least the chemistry used as you have to specify an adapter file to the ILLUMINACLIP argument (not necessarily the exact sequences though). If I wouldn't know the exact chemistry, I would merge all the fasta files in the adapters dir into a single file and use this in the ILLUMINACLIP argument. This probably would not be necessary though, FastQC checks for/reports adapter sequences, that would give a hint on the chemistry used. $\endgroup$
    – haci
    Commented Dec 9, 2019 at 8:47
  • $\begingroup$ @Haci: that what I did initially yesterday but it did not work so I decided to write again here. Today I added the full path to the Nextera file and worked finally. My question is there a way to not write the full path for the file in the illuminaclip step? Also, I still see in the report loads of over represented sequences after the clip, what should someone do with those? $\endgroup$
    – Skepto18
    Commented Dec 9, 2019 at 11:53
  • 1
    $\begingroup$ For your first question, you can place a copy of the adapter file in the directory from which you are running your command. For your second question, over-represented sequences are not necessarily arise from adapter sequences. You might want to blast them to see what they might be (low complexity regions, contamination, ...) But if you really would like to remove them, just add them to the end of your adapter file as a fasta entry and Trimmomatic will take care of them. $\endgroup$
    – haci
    Commented Dec 9, 2019 at 12:04

I came across the same problem of Nextera transposase contamination in my shotgun metagenome sequence. I specified the library in trimmomatic and Nextera transposase adapters were successfully removed. Please see the code below:

java -jar /opt/software/Trimmomatic/0.39-Java-1.8/trimmomatic-0.39.jar PE -phred33 1004_R1.fastq.gz 1004_R2.fastq.gz ../QC_data/1004_R1.fastq.gz ../QC_data/1004.qcup_R1.fastq.gz ../QC_data/1004_R2.fastq.gz ../QC_data/1004.qcup_R2.fastq.gz ILLUMINACLIP:/opt/software/Trimmomatic/0.39-Java-1.8/adapters/NexteraPE-PE.fa:2:30:10 LEADING:3 TRAILING:3 SLIDINGWINDOW:4:15 MINLEN:36

The output showed completed successfully with the following message:

TrimmomaticPE: Started with arguments:
 -phred33 1004_R1.fastq.gz 1004_R2.fastq.gz ../QC_data/1004_R1.fastq.gz ../QC_data/1004.qcup_R1.fastq.gz ../QC_data/1004_R2.fastq.gz ../QC_data/1004.qcup_R2.fastq.gz ILLUMINACLIP:/opt/software/Trimmomatic/0.39-Java-1.8/adapters/NexteraPE-PE.fa:2:30:10 LEADING:3 TRAILING:3 SLIDINGWINDOW:4:15 MINLEN:36
ILLUMINACLIP: Using 1 prefix pairs, 4 forward/reverse sequences, 0 forward only sequences, 0 reverse only sequences
Input Read Pairs: 18205918 Both Surviving: 10467310 (57.49%) Forward Only Surviving: 7470543 (41.03%) Reverse Only Surviving: 48503 (0.27%) Dropped: 219562 (1.21%)
TrimmomaticPE: Completed successfully

And the QC report showed the Nextera transposase was successfully removed. [![QC report][2]][2] enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.