0
$\begingroup$

I know that I don't have the correct format in my .ped file for PLINK but I don't know how to convert it. My actual file is something like:

BSCAN BSCAN20016 0 0 2 0 0 1 1 1....
BSCAN BSCAN20017 0 0 2 0 0 1 1 1....
BSCAN BSCAN20018 0 0 2 0 0 1 1 1....

Where column 1 is FamilyID, column 2 is ID, column 3 is FatherID, column 4 MotherID, column 5 Sex and then the genotype of each individual. I only need to create binary files, so I tried to run:

plink-1.9-rc --file admixed --make-bed --no-pheno --cow --out admixed

but the program shows: Error: half-missing call in .ped file at variant 1, line 1.

Anyone know how can I change the format or recode it to make a correct input?

Thanks in advance!

$\endgroup$
0
$\begingroup$

So, columns 7 and 8 should be the genotype of variant 1 (each column is one of the alleles). You have them as 0 1, which means absent and major allele.

I think you're just missing a column. From the doc:

Column 6 is Phenotype value ('1' = control, '2' = case, '-9'/'0'/non-numeric = missing data if case/control)

Ideally you would know which SNPs are heterozygous based on your SNP calling and have such SNPs as 1 2, but if you have a homozygous organism or if you're working with data that's been flattened you can simply generate the .ped file with the same number twice for each SNP.

$\endgroup$
9
  • $\begingroup$ Thanks for your reply. So, I need to phase the data? Because now I have one column per SNP. I don't have the phenotype column but I specify in the command "--no-pheno" $\endgroup$ – aguillenea Jan 17 '20 at 14:47
  • $\begingroup$ Yeah you're right that --no-pheno should mean it can read them fine, but it says specifically that the first variant in the first column is half-empty. Can you try after adding a phenotype column? You can use -9 to indicate you don't have one. $\endgroup$ – Thymine Jan 17 '20 at 15:02
  • $\begingroup$ Oh, is your example not your real data maybe? I assumed it was real aside from there being more lines and columns $\endgroup$ – Thymine Jan 17 '20 at 15:04
  • $\begingroup$ Actually, it is quite similar to my real data... but I have 5564 individuals (rows) and 46465 SNPs (columns). I will try adding the phenotype column... $\endgroup$ – aguillenea Jan 17 '20 at 15:07
  • $\begingroup$ I have the same error with the phenotype column. $\endgroup$ – aguillenea Jan 17 '20 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.