I'm trying to run MaxQuant on a linux laptop, hower I'm constantly running into problems with MaxQuant crashing at different stages

I tried to use

  • mono 6.8
  • mono 5.4.1


  • centos
  • ubuntu

each with MaxQuant

  • 1.6.3
  • 1.6.7
  • 1.6.11

(everything using docker), but I had no success so far.

I also tried to use the ahead of time compilation of mono, also without sucess. MQ mostly stalls at the "preparing searches" stage.

Has anyone managed to get MQ running properly on linux and can tell me, which linux distro/version, mono version and MQ version you are using?

Any other help is of course also welcome


2 Answers 2


There is a conda package for maxquant that should work on most platforms (I've used it on CentOS and I think it's been used on Ubuntu as well). There's also a docker container version of that that we (Bioconda) have posted to the biocontainers project that should also work.

Please note that large parts of a maxquant analysis are single threaded, regardless of what you specify. We've also had single analysis runs lasting over a month (even when using 90 threads), so the program can be very slow if your search space is large.


I have been running MaxQuant quite frequently on Linux. I would use conda to create a dedicated environment and install mono.

# create the environment
conda create -n maxquant -c conda-forge mono
# activate the environment
conda activate maxquant
# run any maxquant version
mono /path/to/maxuant/MaxQuantCmd.exe mqpar.xml

This installs a conda environment with mono which is a .NET framework for Linux. I had problems in the past running certain MaxQuant versions that way.

The mqpar.xml that is required can be created with the MaxQuant GUI. And then the path for input files needs to be contained correctly. The path to the fasta file and the raw file. I would create a template file and then parse these filenames into the specific locations.

# mqpar.xml

The combination of maxquant= and mono=5.14 worked and a few other versions. Some versions between 1.6 and 2.x did not work at all.

Specific versions of MaxQuant are also available directly via conda and there is no need to download the zip file. Instead, you can simply install it with:

conda install -c conda-forge -c bioconda maxquant mono=5.14

Recently MaxQuant 2 has been added, and not all previous versions are available and run maxquant with:

maxquant mqpar.xml

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.