1
$\begingroup$

so I'm fairly new to using linux and blast - have encountered an error in my work.

I have created a fasta database with the results in this directory path: ~/class/hw/db

I'm currently trying to run a search against my created database against query sequences in a file called seqs.fas.

My code is as follows: blastn -db $db -query seqs.fas -out q1results.txt

However I keep getting this error: Error: Too many positional arguments (1), the offending value: seqs.fas

Error: (CArgException::eSynopsis) Too many positional arguments (1), the offending value: seqs.fas

I'm not sure what I'm doing wrong here, and would appreciate any advice to fix this, thanks!

$\endgroup$
2
$\begingroup$

I remember having this problem in the past, it was encoding related. Rewriting the -s manually (the dash sign) should fix the issue, please see this.

Problem is a copy & past from the BLAST documentation, all dashes ('–') need to be replaced by hand at the command line.

$\endgroup$
5
  • $\begingroup$ Thanks for the comment - I've tried multiple ways to get rid of this, including typing out from hand, copying/pasting, and even copying the '-' that shows up when i type blastn -help, however I'm still getting the same error. Just to be clear, dashes ('-') refer to the 'minus' sign next to 0 right? (I'm a Mac user) $\endgroup$
    – aislinx
    Mar 6 '20 at 14:09
  • $\begingroup$ The only think that I can think of is the $db variable. Does it somehow contain whitespaces or any other character that the shell would not understand? If the tilde sign (~) is part of what $db corresponds to (like in your question), you can try changing it to the exact path of your database. $\endgroup$
    – haci
    Mar 6 '20 at 14:26
  • $\begingroup$ I've just tried blastn -db ~/5030/hw2/db -query seqs.fas -out q1results.txt but that just straight up shows me a BLAST Database rror: no alias or index file found for nucleotide database in search path $\endgroup$
    – aislinx
    Mar 6 '20 at 14:34
  • $\begingroup$ This is another error, I guess you point out to the wrong database path. $\endgroup$
    – haci
    Mar 6 '20 at 15:34
  • $\begingroup$ Just to be clear, when i'm doing -db, to which should I refer to: the directory where I have my database, or the entire DB path? $\endgroup$
    – aislinx
    Mar 6 '20 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.