1
$\begingroup$

I want to use a local blastn command to BLAST a multifasta file ~700 sequences using following command: blastn -db nt -query fasta_all.fasta -num_alignments 2 -out fasta_blasted.txt but I receive error :BLAST Database error: Error: Not a valid version 4 database.

I use a local nt database which I downloaded today (11th of May 2020) by running update_blastdb.pl --decompress nt [*]. I downloaded this but I did not do any post-processing and just the "raw" download files are in the folder (see image below which shows only a part of the files)

enter image description here

The blast+ I downloaded and installed is ncbi-blast-2.10.0+-x64-linux.tar.gz from https://ftp.ncbi.nlm.nih.gov/blast/executables/blast+/LATEST/

So, both database and blastn version should be the latest. It probably has something to do with either the version of the database or the software, but as it both are the latest version, I find it strange that these would not be compatible. Any ideas what causes this error?

$\endgroup$
2
$\begingroup$

first I recommend you to check your downloaded data with md5 to be sure there was no problem with that step. How many files did you download?

Also I was curious if you had another BLAST+ version installed on your computer. Be sure that blastn is called is a version corresponding to the database you are using.

$\endgroup$
6
  • $\begingroup$ Thank you for your reply. I downloaded 24 files in total, from nt.00 till nt.23. For every nt file there are following extensions available: .nhd .nhi .nhr .nin .nnd .nni .nog .nsq. For every nt file there is a nt.xx.tar.gz.md5 file available. Does that make sense? $\endgroup$ – Robvh May 13 '20 at 9:20
  • $\begingroup$ Try to run md5sum nt.xx.tar.gz.md5 for each xx in 00 to 23. Also I was curious if you had another BLAST+ version installed on your computer. Be sure that blastn is called from your latest version folder. $\endgroup$ – thomas duge de bernonville May 13 '20 at 9:50
  • 2
    $\begingroup$ I think this last issue you adres could be the problem. When I run blastn -version it returns Package: blast 2.6.0, build Jan 15 2017 17:12:27 so not 2.10 which I downloaded. Once I also downloaded blast with conda so perhaps that is the problem. $\endgroup$ – Robvh May 13 '20 at 10:09
  • 1
    $\begingroup$ Thomas, indeed this was the problem, very good suggestion. I removed my BLAST through conda remove blast to remove the old version. I followed the exact steps of ncbi.nlm.nih.gov/books/NBK52640 but this did not lead to a correct installation. The command blastn was not found even after right configuration (check by echo $PATH). Now I recall that I install blast also through conda because the description of NCBI did not work. I now managed to install blast 2.10 by following these steps: ngsprimer.wordpress.com. I receive no error now. Thanks! $\endgroup$ – Robvh May 13 '20 at 11:03
  • 1
    $\begingroup$ Happy to hear it solved the problem! good luck! $\endgroup$ – thomas duge de bernonville May 13 '20 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.