0
$\begingroup$

I am following the tutorial here to learn how to process raw RNA-seq data and get gene read counts. I've had no issues until I got to step 3.9, "Assignment of RNA-Seq Reads to Genes." Here, the authors run the command

fc0 <- featureCounts(sam.list, annot.ext = 
"Ara-port11_GFF3_genes_transposons.201606.gtf", allowMultiOverlap = T, isPairedEnd = F, 
nthreads = 2, strandSpecific = 0, isGTFAnnotationFile = T)

I ran the same command except I set isGTFAnnotationFile = F because I couldn't find the gtf file, so I used the gff file TAIR10_GFF3_genes_transposons.gff instead, downloaded from here (they mentioned that using gtf only speeds up the process but that you can still do this using gff). I'm not sure if this is what is causing the issue, but the error I get is:

Error: Line 1 contains a format error. The expected annotation format is SAF.
Error in featureCounts(sam.list, annot.ext = "TAIR10_GFF3_genes_transposons.gff",  : 
  No counts were generated.
$\endgroup$
  • 1
    $\begingroup$ If you set it to FALSE then FC expects it to be in the SAF format. Leave it as TRUE, that should work. $\endgroup$ – ATpoint Jun 5 at 18:05
  • $\begingroup$ this is what I get now $\endgroup$ – An Ignorant Wanderer Jun 5 at 18:50
  • $\begingroup$ ERROR: failed to find the gene identifier attribute in the 9th column of the provided GTF file. The specified gene identifier attribute is 'gene_id' An example of attributes included in your GTF annotation is 'Parent=AT1G01010.1' The program has to terminate. Error in featureCounts(sam.list, annot.ext = "TAIR10_GFF3_genes_transposons.gff", : No counts were generated. $\endgroup$ – An Ignorant Wanderer Jun 5 at 18:50
  • $\begingroup$ I ended up using the annotation file from support.illumina.com/sequencing/sequencing_software/… and it worked $\endgroup$ – An Ignorant Wanderer Jun 5 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.