0
$\begingroup$

I am trying to run my alignment script that works locally, using SBATCH.

Official manual for bowtie2 says I can use samtools for that. However when I run the following script I have an error

line 22: bowtie2: command not found

Below is the script:

#!/bin/bash

#SBATCH --time=05:00:00
#SBATCH --account=def-myaccount
#SBATCH --mem=200000M
#SBATCH [email protected]
#SBATCH --mail-type=All


module load nixpkgs/16.09  intel/2018.3
module load samtools/1.9



for FILE in *R1_001.fastq.gz;

do
        BASENAME=${file%%_R1_001.fastq.gz*}

        NUM=`echo $FILE | sed 's/_S.*$//'`

        bowtie2 -x cov_nastya -U $FILE -S ${NUM}exit.sam

done
$\endgroup$

1 Answer 1

3
$\begingroup$

It seems you do not have bowtie installed or loaded. Use module load bowtie2 together when you load samtools.

$\endgroup$
2
  • $\begingroup$ Thank you, it worked. Just a general inquiry at the end.. Is samtools really necessary here? Thanks. $\endgroup$ Commented Feb 10, 2021 at 22:56
  • $\begingroup$ From your script samtools does not seem to be necessary. $\endgroup$
    – Phoenix Mu
    Commented Feb 11, 2021 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.