1
$\begingroup$

Note: this question has also been asked on Biostars

I started getting a strange error when trying to load GEOquerry with library(GEOquerry).

Error: package or namespace load failed for ‘GEOquery’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]): namespace ‘rlang’ 0.4.9 is already loaded, but >= 0.4.10 is required

When I run > devtools::install_github('r-lib/rlang') I get ...

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) : 
  namespace ‘rlang’ 0.4.9 is already loaded, but >= 0.4.10 is required

Has anyone dealt with this before? Restarting my R session has no effect.

$\endgroup$
0
1
$\begingroup$

rlang 0.4.10 is the current version at CRAN: https://cran.r-project.org/web/packages/rlang/index.html

Try to install it via install.packages, not via GitHub directly.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.