1
$\begingroup$

I need suggestions in creating index and dictionary with vcf files. For the base recalibration step, I downloaded Homo_sapiens_assembly38.known_indels.vcf.gz from the given link: https://console.cloud.google.com/storage/browser/genomics-public-data/resources/broad/hg38/v0;tab=objects?prefix=&forceOnObjectsSortingFiltering=false

I am using GATK version 4.2.2.0

When I try to create index and dictoionary of the vcf file, I get the following error: no suitable codecs found. I also tried to check the vcf file using ValidateVariants and I get the same error: no suitable codecs found.

Can anyone suggest which indels vcf file is used for masking sites in the base recalibration step. Has anyone come across this above error and how did they resolve the issue.

Thanks

$\endgroup$
1
  • 1
    $\begingroup$ Can you show which commands are you trying on the file? $\endgroup$
    – JRodrigoF
    Oct 2, 2021 at 14:53

1 Answer 1

1
$\begingroup$

I have also encountered this error before in cases where there was something wrong with the VCF file I was supplying.

  • Double check your command to ensure that you are feeding it the file you believed you were and verify that file is a vcf (gzipped or otherwise)
  • If you know how, please compare MD5 or SHA checksums of your copy vs. the original to ensure you have an uncorrupted copy.
  • If this is something you haven't dealt with before, a less effective version would be to check and make sure that the file size on the server is the same as the file size on your machine.
  • Additionally, you may want to just use the less command to look inside the file and see if anything appears to be corrupted (you may need to decompress it for that purpose).
  • It may also be worth trying to gunzip or gzip -d commands to decompress the file (assuming you have the drive space). This will both ensure that decompressing the file on the fly is not causing any grief to GATK (which is unlikely) and that the file decompresses without error (which would also be an indication of corruption).
  • Lastly, you could try downloading a fresh version. Please let me know if this helps and you discover the source of the error.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.