I'm using this Jupyter notebook to work on R... How do I do the equivalent of ?someFun?

When I run that in the notebook, I get:

Warning message in seq_len(head.end.idx):
“first element used of 'length.out' argument”
ERROR while rich displaying an object: Error in seq_len(head.end.idx): argument must be coercible to non-negative integer

1. FUN(X[[i]], ...)


When I execute docker run jupyter/r-notebook I notice that it does pop up the widget (after throwing the error). Not it isn't a popup window, but a panel at the bottom of the workbook. My notebook is 'Trusted', which I think is significant, but I don't know how to turn it off.

When I execute docker run -e JUPYTER_ENABLE_LAB=yes jupyter/r-notebook I get the error and the widget does not pop up. I'm not sure how to set or inspect the JS trust in that environment. I suspect it's related. I don't see any blocked popups in the browser.

Strange that even when it works (the widget opens at the bottom of the browser) I still get an error in the output.


3 Answers 3


If you launch like docker run -p 8888:8888 jupyter/r-notebook you will get the help page like a widget and a warning in your cell output. Check your browser, maybe is blocking pop-up elements.


  • $\begingroup$ Thanks for showing me what the widget looks like. I do see this now (i.e. working correctly), but only when not setting JUPYTER_ENABLE_LAB=yes $\endgroup$
    – Dan Bolser
    Commented Oct 21, 2021 at 10:00

I met the same problem. R after v4.1.1 seem to have problems with repr_html. I fixed the problem by following the quotes.

This tiny commit solves a long standing problem while trying to read help from inside jupyterlab.

In order not to wait for the PR to be merged, you may just install from @renkun-ken 's fork: devtools::install_github("renkun-ken/repr", ref = "fix-html-filter")





I think error is not related to ?. This is what I see when I try ?seq:

enter image description here

  • 1
    $\begingroup$ Yes, help(seq) and ?seq are both a problem. I think it's related to trusted JS execution... I think... $\endgroup$
    – Dan Bolser
    Commented Oct 21, 2021 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.