when I run a short search in blastn locally with less than 16 nucleotides with nt.00 database I don't get any found match, but if I increase the searched string 2 nucleotides it finds matches, so the 14 string was in the BD. Also, when I run the same 14 nucleotides search in a BD created with homo-sapiens Y chromosome it finds matches. This BD was created with the command:

makeblastdb -in homoy.fasta -out homoydb -dbtype 'nucl' -parse_seqids -hash_index

As you see it includes -parse_seqids -hash_index parameters. The command for search is (replacing homoydb with nt.00 in the first case):

blastn -task blastn-short -query myqueryin.fa -db homoydb -out myout.txt

So why blast nt preformatted databases don't find sequences shorter than 16 if they are in the BD and with my own DB find them OK?



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.