1
$\begingroup$

I am using Lexogen's Quantitative Sequencing Pool Analysis tool (here: https://github.com/Lexogen-Tools/quantseqpool_analysis) to analyze R1 and R2 files.

I have been able to successfully run this tool. However, I need to downsample and then normalize these results so I need to do this all again.

To downsample, I put the R1s (the ones generated after idemultiplexing) through the SeqTK_sample tool on UseGalaxy. Afterwards, I ran the QSPA tool with the new R1s and old R2s. I skipped the idemultiplexing part by # out the code. This is generating errors (screenshots are attached). I don't think these errors are from me # out the code but rather from the new R1s with the old R2s. I didn't receive any errors the first time I ran this tool.

I will be normalizing my data with DESeq2 using the summary_unique.tsv file.

If anyone has any tips/suggestions it would be much appreciated. I am sure there is a better way to do this. If you require anything from me just ask!

Cheers,

enter image description here

enter image description here

$\endgroup$
4
  • 1
    $\begingroup$ I don't know anything about this software in particular, but the traceback in the first screenshot makes it look like a compressed file is truncated. QuantSeqPool calls cutadapt which in a roundabout way uses isal-l which uses isal.igzip which finally gives the "Compressed file ended" error. I'd back up a step and look into what file is being given to cutadapt and why it's truncated. $\endgroup$
    – Jesse
    Commented Nov 19, 2021 at 18:16
  • $\begingroup$ Thanks for the advice, Jesse! I compressed these files and loaded them onto the server. I then unzipped them using jar xf as conventional unzip methods weren't working. Do you think this could be an issue? $\endgroup$ Commented Nov 19, 2021 at 18:51
  • $\begingroup$ Sorry for the delay. I wonder if something went wrong during that process (truncated zip file?) and that might explain why "conventional" tools weren't working for you to unzip. I'd suggest using a checksum program on both your local copy and the server copy (md5sum, sha256sum, whatever's available) and re-uploading any files that don't match. $\endgroup$
    – Jesse
    Commented Nov 26, 2021 at 18:00
  • $\begingroup$ I ended up figuring things out. I will post the solution for others to see. $\endgroup$ Commented Dec 1, 2021 at 15:39

1 Answer 1

0
$\begingroup$

The issue was that we downsampled with useGalaxy's SeqTK tool prior to running UMI-tools and cutadapt (the 2nd and 3rd process, respectively, of Quantitative Sequencing Pool Analysis).

I tried downsampling with the R1 data, available after cutadapt (located in the "trimmed" folder), and everything ran fine. I believe the issues were caused by the barcode sequences being removed by the SeqTK tool prior to running UMI-tools.

You can (somewhat) customize the QSPA script by #'ing out parts of the script that you don't want to run. In this case, I #'d out Star Aligner, UMI-tools (deduplication), and Feature Counts so that the script would stop after cutadapt. After I downsampled with SeqTK, I ran the script using only the parts that I had previously #'d out.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.