I tried to install vcf2maf following this tutorial from GitHub: https://github.com/mskcc/vcf2maf.

I get a repeat error when I try to test out vcf2maf using the code:

perl vcf2maf.pl --input-vcf tests/test.vcf --output-maf tests/test.vep.maf

The error message looks like this:

'''STATUS: Running VEP and writing to: tests/test.vep.vcf
ERROR: Cannot find VEP script under: /Users/user/miniconda3/bin'''

Basically I followed every steps provided on the tutorial. Does anyone could help me find out what is going wrong?

I am working on macOS Monterey 12.2.1 with an Intel Core i5 processor.

  • $\begingroup$ Could you kindly provide details of your hardware and system? $\endgroup$
    – M__
    Feb 14, 2022 at 20:28
  • $\begingroup$ I have the same problem. I tried conda installation as indicated, however, the error is not solved. Perl version is v5.36.0. $\endgroup$
    – user15601
    Jun 9, 2022 at 2:06

1 Answer 1


Install it via anaconda/conda either,

conda install -c bioconda vcf2maf
conda install -c bioconda/label/cf201901 vcf2maf

I would be surprised if that installation fails. A possible issue is Perl version and system version.

  • $\begingroup$ Thanks! I think that works! $\endgroup$
    – Scott XU
    Feb 14, 2022 at 20:34
  • $\begingroup$ Cool, please remember to 'accept' and if possible upvote $\endgroup$
    – M__
    Feb 14, 2022 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.