2
$\begingroup$

I was wondering if somebody here has experience with installing scvi-tools on a Mac with M1 chip. I tried the following command:

conda install scvi-tools -c conda-forge

But got the following error:

Collecting package metadata (current_repodata.json): failed
CondaSSLError: OpenSSL appears to be unavailable on this machine. OpenSSL is required to
download and install packages.
Exception: HTTPSConnectionPool(host='conda.anaconda.org', port=443): Max retries exceeded with url: /conda-forge/osx-64/current_repodata.json (Caused by SSLError("Can't connect to HTTPS URL because the SSL module is not available."))

Then I tried to install OpenSSL with following command:

conda install -c anaconda openssl 

and I got the exact same error as the conda install scvi-tools -c conda-forge command.

I do not understand why collection of metadata is failing for openssl. Any inputs would be highly helpful. Thanks!

$\endgroup$
2
  • $\begingroup$ There might be system incompatibilities, thats what my error log suggests. Thus I was unable to easily install as well. However this might be a Python version issue (could be Python 3.6, I used 3.11 [not the best idea]). However the error log should have flagged that. scvi-tools is a bioinformatics tool, but please try and edit the question with the biological problem. I'd guess this is RNA-seq PCA type analysis $\endgroup$
    – M__
    Commented Nov 30, 2022 at 22:10
  • $\begingroup$ Wait, how did you end up with a non-working conda install on that M1 mac in the first place? Looks like it's not complaining about a missing package dependency; it's complaining about not having openssl to do HTTPS downloads within conda. $\endgroup$
    – Jesse
    Commented Dec 1, 2022 at 22:44

1 Answer 1

2
$\begingroup$

Did you try:

pip install scvi-tools

?

$\endgroup$
2
  • 1
    $\begingroup$ Would need venv (virtual env) with pip, but I agree I think this is the best approach in this particular scenario $\endgroup$
    – M__
    Commented Nov 30, 2022 at 22:33
  • $\begingroup$ scvi-tools.org $\endgroup$ Commented Dec 1, 2022 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.