1
$\begingroup$

I am trying to use AnnotSV to annotate some Manta outputs in the following code with the HPO term changed:

Where:

  • input_dir is the input directory
  • singularity_container is the path to the AnnotSV singularity container
# Loop through the files in the input directory
for file in "$input_dir"/*.vcf; do
    # Get the base name of the file without extension
    filename=$(basename "$file" .vcf)

    # Create the output subdirectory within the input directory
    output_dir="$input_dir/AnnotSV_Batch_Run"
mkdir -p "$output_dir"

    # Set the output file path with "_AnnotSV" appended
    output_file="$output_dir/${filename}_AnnotSV_"

    # Run AnnotSV via Singularity with the base name as output prefix
    singularity exec "$singularity_container" AnnotSV -SVinputFile "$file" -genomeBuild GRCh38 --hpo "HP:0000001"  -outputFile "$output_file"
done

The HPO term I am using is in the jax.org site but when I run it - I get the most peculiar error option not known. but the HPO term is specified in the AnnotSV manual on page 49 (according to the number on the bottom). As for trying I tried with --HPOterm and hpoterm I tried with and without the : and with and without quotes as well. I am not sure what the issue is but I cannot seem to find the solution. Has anyone perchance used this software before with HPO terms as it seems not to be accepting the input I give it?

$\endgroup$
15
  • $\begingroup$ The manual says -hpo and you're using --hpo. Could that be the problem? $\endgroup$
    – Ram RS
    Jun 6, 2023 at 14:05
  • $\begingroup$ Now I am getting "/usr/local/share/AnnotSV/Annotations_Human/Genes/GRCh38/refGene.txt.gz" file doesn't exist Please check your install - Exit with error.? $\endgroup$
    – Indira
    Jun 6, 2023 at 19:01
  • $\begingroup$ Try adding a --no-mount flag immediately after singularity exec in the command. $\endgroup$
    – Ram RS
    Jun 6, 2023 at 20:04
  • $\begingroup$ The --no-mount gives the error FATAL: "--no-mount": executable file not found in $PATH - I also tried with usr/local/bin/AnnotSV and it did not work $\endgroup$
    – Indira
    Jun 6, 2023 at 20:08
  • $\begingroup$ Oops, my bad. I did not read the documentation properly, sorry. Try singularity exec --no-mount hostfs AnnotSV $\endgroup$
    – Ram RS
    Jun 6, 2023 at 20:21

1 Answer 1

1
$\begingroup$

It seems that currently AnnotSV does not support HPO terms usage an Singularity.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.