2
$\begingroup$

I was trying to install NCBI AMRFinderPLUS on my Nvidia Jetson using standard Bioconda based installtion. However, all the time it is giving error that the package is not available and I thought I am making some typo or channel is not proper.

(amrfinder) jay@jetmimd-desktop:~$ conda install -y -c conda-forge -c bioconda ncbi-amrfinderplus
Channels:
 - conda-forge
 - bioconda
 - defaults
Platform: linux-aarch64
Collecting package metadata (repodata.json): done
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  - ncbi-amrfinderplus

Current channels:

  - https://conda.anaconda.org/conda-forge
  - https://conda.anaconda.org/bioconda
  - defaults

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.

Then I remembered about the different architecture. So, now here I am. Is there any way to install this on arm64 architecture?

Thank you for the help in advance!!!!

$\endgroup$

1 Answer 1

1
$\begingroup$

Try the following

conda install bioconda::ncbi-amrfinderplus

The above does work I tested it (below). There could be an issue with you version of conda (24.1.2 OSX).

Also has the package has been ported for GPU(?) ... I assume it is, otherwise it's obviously not going to work and conda will not install it

However, if it ported for GPU and still fails use mamba (I don't use mamba BTW), because it is very slow and that could be where the error is (unusually slow).

My connection initially was unsuccessful but resolved via

Retrying with flexible solve.


To demonstrate I got it working here's the reply ...

The following NEW packages will be INSTALLED:

  blast              bioconda/osx-64::blast-2.12.0-pl5262h78c34c6_0
  c-ares             pkgs/main/osx-64::c-ares-1.19.1-h6c40b1e_0
  curl               pkgs/main/osx-64::curl-7.88.1-hdb2fb19_2
  entrez-direct      bioconda/osx-64::entrez-direct-16.2-h193322a_1
  hmmer              bioconda/osx-64::hmmer-3.3.2-hb19a6fa_3
  libcurl            pkgs/main/osx-64::libcurl-7.88.1-ha585b31_2
  libev              pkgs/main/osx-64::libev-4.33-h9ed2024_1
  libidn2            pkgs/main/osx-64::libidn2-2.3.4-h6c40b1e_0
  libnghttp2         pkgs/main/osx-64::libnghttp2-1.52.0-h1c88b7d_1
  libssh2            pkgs/main/osx-64::libssh2-1.10.0-hdb2fb19_2
  libunistring       pkgs/main/osx-64::libunistring-0.9.10-h9ed2024_0
  ncbi-amrfinderplus bioconda/osx-64::ncbi-amrfinderplus-3.11.14-hfee4e81_0
  perl               pkgs/main/osx-64::perl-5.26.2-h4e221da_0
  perl-archive-tar   bioconda/osx-64::perl-archive-tar-2.32-pl526_0
  perl-carp          bioconda/osx-64::perl-carp-1.38-pl526_3
  perl-common-sense  bioconda/osx-64::perl-common-sense-3.74-pl526_2
  perl-compress-raw~ bioconda/osx-64::perl-compress-raw-bzip2-2.087-pl526h6de7cb9_0
  perl-compress-raw~ bioconda/osx-64::perl-compress-raw-zlib-2.087-pl526h770b8ee_0
  perl-exporter      bioconda/osx-64::perl-exporter-5.72-pl526_1
  perl-exporter-tiny bioconda/osx-64::perl-exporter-tiny-1.002001-pl526_0
  perl-extutils-mak~ bioconda/osx-64::perl-extutils-makemaker-7.36-pl526_1
  perl-io-compress   bioconda/osx-64::perl-io-compress-2.087-pl526h6de7cb9_0
  perl-io-zlib       bioconda/osx-64::perl-io-zlib-1.10-pl526_2
  perl-json          bioconda/osx-64::perl-json-4.02-pl526_0
  perl-json-xs       bioconda/osx-64::perl-json-xs-2.34-pl526h04f5b5a_3
  perl-list-moreuti~ bioconda/osx-64::perl-list-moreutils-0.428-pl526_1
  perl-list-moreuti~ bioconda/osx-64::perl-list-moreutils-xs-0.428-pl526_0
  perl-pathtools     bioconda/osx-64::perl-pathtools-3.75-pl526h1de35cc_1
  perl-scalar-list-~ bioconda/osx-64::perl-scalar-list-utils-1.52-pl526h01d97ff_0
  perl-types-serial~ bioconda/osx-64::perl-types-serialiser-1.0-pl526_2
  perl-xsloader      bioconda/osx-64::perl-xsloader-0.24-pl526_0
  wget               pkgs/main/osx-64::wget-1.21.4-ha585b31_1

There is a blast gpu and I'd assume the other library/packages have gpu versions. There's a lot of Perl code there BTW, so it's an old package, before NVIDIA was big perhaps?


If there is a GPU compliant channel on conda (nanoporetch) - that is impressive: especially given the amount of Perl code. Porting for GPU from CPU isn't trivial.

Few versions behind

The key thing is whether the upgrades are fixing bugs or refactoring/adding functionality. If it's the latter then I would go for it because the GPU would compensate for the slower runtime (obviously given you don't need the extra functionality).

$\endgroup$
3
  • $\begingroup$ Hey, Thank you very much! I had tried that yesterday (among the many other things I could try/knew how to try) after posting here. But that also generated extact same error as posted above. I think(it may be basic and I am still not sure) the packages which work for OSX64 may not work for aarch64/arm64 and that is why I am not able to use this streamline way of installation. Although I also came across, separate channel on conda nanoporetch who have stated many packages for aarch64, just one or two versions behind. So, I am still in dilemna what to do! Use the older versions or ... $\endgroup$
    – prekij
    Mar 1 at 10:33
  • $\begingroup$ infact I am not able to install the packages with noarch tag. Now, I am not sure weather this is a trivial information to know how to work around these packages or this is something which will take time in developing. $\endgroup$
    – prekij
    Mar 1 at 10:36
  • 1
    $\begingroup$ @prekij if there's no available package, you will probably have to compile it yourself for the architecture :/ $\endgroup$
    – terdon
    Mar 1 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.