I was able to download all of the SRA files for a specific bioproject using the command:

prefetch -O output_directory --option-file SRR_Acc_List.txt

I then tried the following command to download those SRA files into FASTQ files:

find -name \*.sra -exec bsub fastq-dump --split-3 --gzip {} \;

It gave the error:

find: illegal option -- n
usage: find [-H | -L | -P] [-EXdsx] [-f path] path ... [expression]
       find [-H | -L | -P] [-EXdsx] -f path [path ...] [expression]

I then tried to add the path:

find /Users/lucykelly/Desktop/Assel_paper/output_directory -name '*.sra' -exec bsub fastq-dump --split-3 --gzip {} \;

It gave the error:

find: bsub: No such file or directory

I then tried

find . -name '*.sra' -exec fasterq-dump --gzip {} \;

and it gave the error:

find: fasterq-dump: No such file or directory
  • $\begingroup$ I agree with @ATPoint. At first I thought it was bsub within the Slurm cluster. If you use which fasterq-dump it should throw a blank. The bsub error is weird because you should be on the cluster right? Anyway once diagnosed its easy to solve. $\endgroup$
    – M__
    Mar 13 at 3:05

1 Answer 1


That is a classical problem where the folder containing the binary of the tool is not in PATH, see for example https://askubuntu.com/questions/109381/how-to-add-path-of-a-program-to-path-environment-variable or many other threads towards PATH in the SE network.

  • $\begingroup$ Thank you so much @ATpoint $\endgroup$
    – Lucy
    Mar 13 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.