3
$\begingroup$

Not sure if this is allowed but I cannot think of a better place to ask. I am attempting to download all genomic sequences from refseq associated with the query Peptostreptococcaceae. I have been been using the following command (based on some reading of the manual):

esearch -db nuccore -query "Peptostreptococcaceae" | efilter -molecule genomic -source refseq | efetch -format fasta

But I keep getting the following error

Unknown option: molecule   
Unknown option: source   
Must supply -query or -days or -mindate and -maxdate arguments on command 
line Db value not found in fetch input No do_post output returned from 
'http://eutils.ncbi.nlm.nih.gov/entrez/eutils/esearch.fcgi?db=nuccore&term=Peptostreptococcaceae&retmax=0&usehistory=y&edirect=3.80&tool=edirect&email=lgunn@sonic15' Result of do_post http request is .............
(a lot of text which I assume is .html or .xml related)
$\endgroup$
  • 3
    $\begingroup$ What operating system are you using? I just installed edirect using the instructions you linked to, then ran the exact command you show and it seems to be working fine. Could you be using an older version of edirect that doesn't support these options? $\endgroup$ – terdon Dec 7 '17 at 17:19
  • $\begingroup$ Quite possible. I tried looking up versions but could not find the info. Ill remove it and reinstall it. Fingers crossed. $\endgroup$ – AudileF Dec 7 '17 at 17:22
  • $\begingroup$ That was it @terdon. Thanks. Theres no mention of updates or versions so I assumed the one I had would work fine. $\endgroup$ – AudileF Dec 7 '17 at 17:30
  • 2
    $\begingroup$ Great! Could you please post a quick answer (and then accept it when the system lets you—you need to wait a bit) explaining this? That way, the question can be marked as solved. $\endgroup$ – terdon Dec 7 '17 at 17:32
1
$\begingroup$

The issue here was I was using an older version of eDirect. There is no command to check version or updates. Your best bet is if you experience problems uninstall and reinstall.

$\endgroup$
1
$\begingroup$

If you want to find version info you can either :

Ask for another edirect tool version (it will be the same version for edirect) :

efetch -version

6.80

Check the info contained in the edirect.pl script :

grep -i 'version = ' edirect.pl

$version = "6.80";

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.