4
$\begingroup$

I am trying to install RnBeads from bioconductor but the installation of its dependancy TxDb.Hsapiens.UCSC.hg19.knownGene fails. The error is:

biocLite("RnBeads")
BioC_mirror: https://bioconductor.org
Using Bioconductor 3.6 (BiocInstaller 1.28.0), R 3.4.3 (2017-11-30).
Installing package(s) ‘RnBeads’
also installing the dependencies ‘FDb.InfiniumMethylation.hg19’, ‘methylumi’

trying URL 'https://bioconductor.org/packages/3.6/data/annotation/src/contrib/FDb.InfiniumMethylation.hg19_2.2.0.tar.gz'
Content type 'application/x-gzip' length 38996322 bytes (37.2 MB)
==================================================
downloaded 37.2 MB

trying URL 'https://bioconductor.org/packages/3.6/bioc/src/contrib/methylumi_2.24.1.tar.gz'
Content type 'application/x-gzip' length 6178909 bytes (5.9 MB)
==================================================
downloaded 5.9 MB

trying URL 'https://bioconductor.org/packages/3.6/bioc/src/contrib/RnBeads_1.10.2.tar.gz'
Content type 'application/x-gzip' length 6437974 bytes (6.1 MB)
==================================================
downloaded 6.1 MB

* installing *source* package ‘FDb.InfiniumMethylation.hg19’ ...
** R
** data
** demo
** inst
** preparing package for lazy loading
Error: package or namespace load failed for ‘TxDb.Hsapiens.UCSC.hg19.knownGene’:
 .onLoad failed in loadNamespace() for 'TxDb.Hsapiens.UCSC.hg19.knownGene', details:
  call: NULL
  error: evaluation nested too deeply: infinite recursion / options(expressions=)?
Error : package ‘TxDb.Hsapiens.UCSC.hg19.knownGene’ could not be loaded
ERROR: lazy loading failed for package ‘FDb.InfiniumMethylation.hg19’

The downloaded source packages are in
    ‘/tmp/RtmpY8Yf4l/downloaded_packages’
installation path not writeable, unable to update packages: doMC, doSNOW,
  foreach, iterators, snow, boot, class, cluster, codetools, foreign,
  KernSmooth, lattice, MASS, Matrix, mgcv, nlme, nnet, rpart, spatial, survival

As suggested by the error message, I tried setting options(expressions=500000), which unfortunately did not change the error message. An important note may be that I am under network mount and don't have administrative access rights.

Edit

I don't have a .Rprofile file.

Note about installation path not writeable: Typing .libPaths() reveals that my home R folder is at the first position (and it is writable). The other paths ("/usr/local/lib/R/site-library" , "/usr/lib/R/site-library" and "/usr/lib/R/library") are not writable without sudo.

I also tried to delete my home R folder and to reinstall it. The reinstallation of all packages worked for all packages except for the three listed above (same error message). I also tried biocLite("TxDb.Hsapiens.UCSC.hg19.knownGene", lib.loc=.libPaths()[1], lib=.libPaths()[1]) to specifically address my home R directory, but the same error is showing up (but without the installation path not writeable part).

Here is my sessionInfo():

R version 3.4.3 (2017-11-30)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 14.04.4 LTS

Matrix products: default
BLAS: /usr/lib/openblas-base/libopenblas.so.0
LAPACK: /usr/lib/lapack/liblapack.so.3.0

locale:
 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            
[11] LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C       

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] BiocInstaller_1.28.0

loaded via a namespace (and not attached):
[1] compiler_3.4.3 tools_3.4.3

Thank you very much!

$\endgroup$
  • 1
    $\begingroup$ It might be better then to raise the error to support.bioconductor.org to let the maintainers know about it. $\endgroup$ – llrs Dec 22 '17 at 8:06
  • $\begingroup$ Ok, I will do. If the error is fixable from user side, I will report the answer here. $\endgroup$ – Bluescreen Dec 22 '17 at 8:09
2
$\begingroup$

I have reported the error on support.bioconductor.org but we were not able to solve the problem. It seems that some dependencies are making problems, but as reinstalling my home R folder did not resolve the issue, I have come up with the following workaround:

I downloaded the latest R version from my favorite CRAN mirror, opened an R session with pathToNewR/bin/R from my terminal and installed RnBeads there. This works fine.

Note: I had to make sure that pathToNewR/library is the only entry in .libPaths(), as per default, my home R folder was also contained in .libPaths().

As a consequence, I am independent from the (maybe broken) R version and packages on my server and can finally work with RnBeads :)

| improve this answer | |
$\endgroup$
  • $\begingroup$ If I come up with another solution that works fine with my server R version, I will post an update here. $\endgroup$ – Bluescreen Jan 3 '18 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.