0
$\begingroup$

This is the error that I am getting:

launch_varscan.pl: Creating a pileup /home/user/lyve-SET-1.1.4f/lambda/tmp/NC001416.fasta.wgsim.fastq.gz-reference.sorted.bam.mpileup
removed ‘/home/user/lyve-SET-1.1.4f/lambda/tmp/NC001416.fasta.wgsim.fastq.gz-reference.sorted.bam.1239.mpileup’
launch_varscan.pl: Running mpileup:
  echo "NC_001416.1
" | xargs -P 1 -n 1 -I {} sh -c 'echo "MPileup on {}" >&2; samtools mpileup -f lambda/reference/reference.fasta 
-Q 0 -B  --region "{}" /home/user/lyve-SET-1.1.4f/lambda/bam/NC001416.fasta.wgsim.fastq.gz-reference.sorted.bam > 
/home/user/lyve-SET-1.1.4f/lambda/tmp/NC001416.fasta.wgsim.fastq.gz-reference.sorted.bam.$$.mpileup'
MPileup on NC_001416.1
mpileup: unrecognized option '--region'
open: No such file or directory
[mpileup] failed to open NC_001416.1: No such file or directory
launch_varscan.pl: main::mpileup: ERROR with xargs and samtools mpileup
Stopped at /home/arahat/lyve-SET-1.1.4f/scripts/launch_varscan.pl line 106.
QSUB ERROR
31488
launch_set.pl: Schedule::SGELK::command: ERROR with command: Inappropriate ioctl for device
  /usr/bin/perl /home/user/lyve-SET-1.1.4f/lambda/log/SGELK/qsub.2705.pl
Stopped at /home/user/lyve-SET-1.1.4f/scripts/../lib/Schedule/SGELK.pm line 661.
set_test.pl: ERROR: died while trying to run COMMAND
  launch_set.pl lambda --numcpus 1 --numnodes 20
set_test.pl: See if you have the correct software installed for this command.
6400 at /home/arahat/lyve-SET-1.1.4f/scripts/set_test.pl line 94.
make: *** [test] Error 25

I think the main problem is the "mpileup: unrecognized option --region", which seems to be blank. In the beginning of the block, it says creating pileup and then it immediately removes the file, probably to create the pipeline file.

I cannot change the code for Lyve-SET pipelining or create shell scripts for the pipeline because I am only configuring my server for use with the genome sequencing pipeline. Would this be a problem with the data set or some tool that I need to install? Any insight would be appreciated.

$\endgroup$
5
  • $\begingroup$ What version of samtools mpileup to you have installed? What version of varscan are you using? Did you install the two tools separately or did varscan come with samtools? I have version 1.3.1 and there is a --region option for mpileup. $\endgroup$
    – Bioathlete
    Dec 27 '17 at 16:56
  • $\begingroup$ Have you tried running samtools mpileup -f lambda/reference/reference.fasta -Q 0 -B --region NC_001416.1 /home/user/lyve-SET-1.1.4f/lambda/bam/NC001416.fasta.wgsim.fastq.gz-reference.sorted.bam directly to see if the command works outside the context of varscan? $\endgroup$
    – Bioathlete
    Dec 27 '17 at 16:59
  • $\begingroup$ I installed samtools version 0.1.19 using yum install. Varscan was installed separately through make install from Lyve-SET. I did not try to run samtools mpileup separately because all the commands are implemented through Lyve-SET, which is how it will be run by the user. I will try reinstalling varscan and running the samtools mpileup command separately. Thank you for the help. $\endgroup$
    – Drops
    Dec 27 '17 at 17:06
  • $\begingroup$ I would suggest installing a more recent version of samtools. That version is from 2013 is likely is not compatible with the version of varscan you installed $\endgroup$
    – Bioathlete
    Dec 27 '17 at 17:15
  • $\begingroup$ Yup. I noticed that yum patches but does not update the packages so I am manually installing the newest versions of all the tools specified in Lyve-SET. Thank you for bringing this to my attention. Hopefully it works after I reinstall. $\endgroup$
    – Drops
    Dec 27 '17 at 17:21
0
$\begingroup$

The samtools v0.1.19 manual confirms that there is no --region option. In that version there is only the -r argument to pass in the targeted region. If you update to a newer version of samtools this should execute correctly

$\endgroup$
1
  • $\begingroup$ It worked after I reinstalled all the tools. The main problem was the mpileup error where --region was not an option. Cannot trust some of these yum packages as they are much older versions. Thank you so much for helping me with this issue. $\endgroup$
    – Drops
    Dec 27 '17 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.