0
$\begingroup$

I am trying to install blasr on mac osx.

I followed the steps here

I get the error below after using the 'make' command:

make PREFIX=/tmp/pitchfork blasr
Cloning into 'pitchfork'...
remote: Counting objects: 10203, done.
remote: Compressing objects: 100% (51/51), done.
remote: Total 10203 (delta 25), reused 51 (delta 18), pack-reused 10128
Receiving objects: 100% (10203/10203), 1.16 MiB | 207.00 KiB/s, done.
Resolving deltas: 100% (5413/5413), done.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -f mk/init.mk init
/Users/cr517/Documents/pitchfork/bin/checkSystem
/Users/cr517/Documents/pitchfork/bin/checkCC gcc
mkdir -p "/Users/cr517/Documents/pitchfork/workspace"
mkdir -p "/Users/cr517/Documents/pitchfork/distfiles"
mkdir -p "/Users/cr517/Documents/pitchfork/staging"
mkdir -p "/tmp/pitchfork/bin"
mkdir -p "/tmp/pitchfork/etc"
mkdir -p "/tmp/pitchfork/include"
mkdir -p "/tmp/pitchfork/lib"
mkdir -p "/tmp/pitchfork/lib/pkgconfig"
mkdir -p "/tmp/pitchfork/share"
mkdir -p "/tmp/pitchfork/var/pkg"
echo "export DYLD_LIBRARY_PATH=/tmp/pitchfork/lib:\$DYLD_LIBRARY_PATH"|sed -e 's/::*/:/g' > "/tmp/pitchfork/setup-env.sh"
echo "export PATH=/tmp/pitchfork/bin:\$PATH"|sed -e 's/::*/:/g' >> "/tmp/pitchfork/setup-env.sh"
echo "OLDPS1=\$PS1" >> "/tmp/pitchfork/setup-env.sh"
echo "[[ \"\$PS1\" ]] && PS1=\"pitchfork($(/Users/cr517/Documents/pitchfork/bin/pitchfork short-branch)) \$PS1\" || PS1=\($(/Users/cr517/Documents/pitchfork/bin/pitchfork short-branch)\)" >> "/tmp/pitchfork/setup-env.sh"
touch mk//../initialized.o
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ports/thirdparty/zlib do-install
make[1]: Nothing to be done for `do-install'.
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ports/thirdparty/libbzip2 do-install
rm -rf /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6
mkdir -p /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/lib/pkgconfig /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/include /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/bin
cp -aL /usr/bin/bzip2 /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/bin/
cp -aL /usr/include/bzlib.h /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/include
cp -aL /usr/lib/libbz2.* /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/lib
ln -sfn libbz2.dylib.1.0 /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/lib/libbz2.dylib.1
ln -sfn libbz2.dylib.1   /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/lib/libbz2.dylib
sed -e "s@^prefix=.*@prefix=/tmp/pitchfork@" bzip2.pc > /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/lib/pkgconfig/bzip2.pc
cd /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6 && tar cf - * | tar xf - -C /tmp/pitchfork
find /Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6 ! -type d|awk -F '/Users/cr517/Documents/pitchfork/staging/libbzip2-1.0.6/' '{print $2}' > /tmp/pitchfork/var/pkg/libbzip2-1.0.6
/Applications/Xcode.app/Contents/Developer/usr/bin/make -C ports/thirdparty/boost do-install
/Users/cr517/Documents/pitchfork/bin/pitchfork fetch --url https://prdownloads.sourceforge.net/boost/boost_1_60_0.tar.gz
fetching https://prdownloads.sourceforge.net/boost/boost_1_60_0.tar.gz
{'url': 'https://prdownloads.sourceforge.net/boost/boost_1_60_0.tar.gz', 'subcommand': 'fetch'}
Traceback (most recent call last):
  File "/Users/cr517/Documents/pitchfork/bin/pitchfork", line 525, in <module>
    sys.exit(main())
  File "/Users/cr517/Documents/pitchfork/bin/pitchfork", line 518, in main
    pitchfork(pargs)
  File "/Users/cr517/Documents/pitchfork/bin/pitchfork", line 444, in pitchfork
    raise Exception("[ERROR] %s" % ''.join(_err))
Exception: [ERROR] --2018-01-24 00:35:30--  https://prdownloads.sourceforge.net/boost/boost_1_60_0.tar.gz
Resolving prdownloads.sourceforge.net... 216.34.181.59
Connecting to prdownloads.sourceforge.net|216.34.181.59|:443... connected.
ERROR: cannot verify prdownloads.sourceforge.net's certificate, issued by ‘CN=COMODO RSA Domain Validation Secure Server CA,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB’:
  Unable to locally verify the issuer's authority.
To connect to prdownloads.sourceforge.net insecurely, use `--no-check-certificate'.
make[1]: *** [boost_1_60_0.tar.gz] Error 1
make: *** [boost] Error 2

I think the important info is here:

raise Exception("[ERROR] %s" % ''.join(_err))
    Exception: [ERROR] --2018-01-24 00:35:30--  https://prdownloads.sourceforge.net/boost/boost_1_60_0.tar.gz
    Resolving prdownloads.sourceforge.net... 216.34.181.59
    Connecting to prdownloads.sourceforge.net|216.34.181.59|:443... connected.
    ERROR: cannot verify prdownloads.sourceforge.net's certificate, issued by ‘CN=COMODO RSA Domain Validation Secure Server CA,O=COMODO CA Limited,L=Salford,ST=Greater Manchester,C=GB’:
      Unable to locally verify the issuer's authority.
    To connect to prdownloads.sourceforge.net insecurely, use `--no-check-certificate'.

but how can I specify the --no-check-certificate option? That's not a make option, I've tried it.

I tried homebrew but got this message:

Updating Homebrew...
==> Auto-updated Homebrew!
Updated 2 taps (caskroom/cask, caskroom/versions).
Warning: Calling 'depends_on :mysql' is deprecated!
Use 'depends_on "mysql"' instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blat.rb:19:in `<class:Blat>'
Please report this to the brewsci/science tap!

Warning: Calling 'depends_on :python3' is deprecated!
Use 'depends_on "python3"' instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/matplotlib.rb:56:in `<class:Matplotlib>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/plink.rb:23:in `block in <class:Plink>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/plink.rb:23:in `block in <class:Plink>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/plink.rb:23:in `block in <class:Plink>'
Please report this to the brewsci/science tap!


Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

==> Installing blasr from brewsci/science
Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:27:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

Warning: Calling <<-EOS.undent is deprecated!
Use <<~EOS instead.
/usr/local/Homebrew/Library/Taps/brewsci/homebrew-science/Formula/blasr.rb:36:in `block in <class:Blasr>'
Please report this to the brewsci/science tap!

==> Downloading https://github.com/PacificBiosciences/blasr/archive/smrtanalysis
Already downloaded: /Users/cr517/Library/Caches/Homebrew/blasr-2.2.tar.gz
==> make STATIC= HDF5INCLUDEDIR=/usr/local/opt/hdf5/include HDF5LIBDIR=/usr/loca
Last 15 lines from /Users/cr517/Library/Logs/Homebrew/blasr/01.make:
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1/memory:4912:1: note: candidate template ignored: could not match 'shared_ptr<type-parameter-0-0>' against 'const RegionAnnotation'
operator<(const shared_ptr<_Tp>& __x, const shared_ptr<_Up>& __y) _NOEXCEPT
^
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1/memory:4977:1: note: candidate template ignored: could not match 'shared_ptr<type-parameter-0-0>' against 'const RegionAnnotation'
operator<(const shared_ptr<_Tp>& __x, nullptr_t) _NOEXCEPT
^
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/include/c++/v1/memory:4985:1: note: candidate template ignored: could not match 'shared_ptr<type-parameter-0-0>' against 'const int'
operator<(nullptr_t, const shared_ptr<_Tp>& __x) _NOEXCEPT
^
1 error generated.
make[1]: *** [bin/KBandMatcher.o] Error 1
make: *** [alignment-build] Error 2
make: *** [sequtils-build] Error 2
clang++  -O3 -Wno-div-by-zero -I ..//common -I /usr/local/opt/hdf5/include bin/PrintPBBWT.o -o bin/bwtpbPrint -L/usr/local/opt/hdf5/lib -lz -lpthread
clang++  -O3 -Wno-div-by-zero -I ..//common -I /usr/local/opt/hdf5/include bin/BWTQuery.o -o bin/bwtquery -L/usr/local/opt/hdf5/lib -lz -lpthread

If reporting this issue please do so at (not Homebrew/brew or Homebrew/core):
https://github.com/brewsci/homebrew-science/issues

I still need to report the issue at the provided address.

I tried Anaconda 'conda install -c bioconda blasr ':

PackageNotFoundError: Packages missing in current channels:

  - blasr

We have searched for the packages in the following channels:

  - https://conda.anaconda.org/bioconda/osx-64
  - https://conda.anaconda.org/bioconda/noarch
  - https://conda.anaconda.org/conda-forge/osx-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://conda.anaconda.org/r/osx-64
  - https://conda.anaconda.org/r/noarch
  - https://repo.continuum.io/pkgs/main/osx-64
  - https://repo.continuum.io/pkgs/main/noarch
  - https://repo.continuum.io/pkgs/free/osx-64
  - https://repo.continuum.io/pkgs/free/noarch
  - https://repo.continuum.io/pkgs/r/osx-64
  - https://repo.continuum.io/pkgs/r/noarch
  - https://repo.continuum.io/pkgs/pro/osx-64
  - https://repo.continuum.io/pkgs/pro/noarch
$\endgroup$
4
  • $\begingroup$ You need to have the certificate to download (securely) the files. Maybe you can try to do download it via wget to obtain the certificate and then check again with make to install it $\endgroup$
    – llrs
    Jan 24 '18 at 8:04
  • $\begingroup$ according to this, there's only a conda recipe for linux-64, not osx-64 $\endgroup$ Jan 25 '18 at 15:44
  • $\begingroup$ @heathobrien, ok, but I've got this error after I install it on Linux. blasr -h blasr: error while loading shared libraries: libhdf5_cpp.so.12: cannot open shared object file: No such file or directory $\endgroup$ Jan 25 '18 at 16:03
  • $\begingroup$ If I were you, I'd give this a try: github.com/muccg/docker-blasr $\endgroup$ Jan 25 '18 at 16:10
3
$\begingroup$

The path of least resistance is probably to run the software inside a container. If you install docker, you can just do the following:

git clone https://github.com/muccg/docker-blasr.git
docker-blasr/bin/blasr

(this worked for me on OSX 10.11.6)

$\endgroup$
1
$\begingroup$

is there reason why you want to compile it by your own? You can install blasr though homebrew and brewsci/science tap :

brew tap brewsci/science
brew install blasr
$\endgroup$
2
  • $\begingroup$ I edited my question to include the error from homebrew. $\endgroup$ Jan 24 '18 at 22:01
  • $\begingroup$ Unfortunately I do not know what is this error, I guess it will be some Xcode-Homebrew versions incompatibility. Best would be to ask directly at github page of homebrew. $\endgroup$
    – Kamil S Jaron
    Jan 25 '18 at 12:43
1
$\begingroup$

I've had many issues with installing blasr on my own, but it's a breeze using (bio)conda, see https://anaconda.org/bioconda/blasr

conda install -c bioconda blasr 
$\endgroup$
4
  • $\begingroup$ I added my trial with conda in my question. Did it succeed on Max OSX for you? $\endgroup$ Jan 25 '18 at 15:42
  • $\begingroup$ I tried in on a GNU/Linux server and got this message after firing up blasr's help: blasr -h blasr: error while loading shared libraries: libhdf5_cpp.so.12: cannot open shared object file: No such file or directory $\endgroup$ Jan 25 '18 at 16:02
  • $\begingroup$ This seems like a missing library on the server. Did you try to install (or get installed) packages related to libhdf5? $\endgroup$
    – llrs
    Jan 25 '18 at 17:05
  • $\begingroup$ @charlesdarwin I used conda to install it on CentOS Linux, and it indeed seems unavailable for Mac OSX. Oops, sorry! $\endgroup$ Jan 26 '18 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.