I download the Albacore wheel from Oxford Nanopore.

I activated my conda environment that has Python 3 as the default python version.

I tried to install Albacore with

pip3 install ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl

but got the following error:

ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl is not a supported wheel on this platform.
You are using pip version 8.1.2, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.`

I then upgraded my pip with:

pip install --upgrade pip
Requirement already up-to-date: pip in /Users/.../anaconda3/envs/python3env/lib/python3.6/site-packages`

So it seems that my pip was already up to date. I do not understand why it complains about my pip if I am using pip3 anyways. I tried to install Albacore again but I got the same message as before.

Can anyone help me install Albacore on my Mac El Capitan laptop, please?

Update based on Wouter's suggestion:

python -m pip install ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl
Processing ./ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl
Requirement already satisfied: python-dateutil in /Users/userName/anaconda3/lib/python3.6/site-packages (from ont-albacore==2.1.10)
Requirement already satisfied: setuptools in /Users/userName/anaconda3/lib/python3.6/site-packages (from ont-albacore==2.1.10)
Requirement already satisfied: h5py in /Users/userName/anaconda3/lib/python3.6/site-packages (from ont-albacore==2.1.10)
Collecting progressbar33 (from ont-albacore==2.1.10)
Requirement already satisfied: numpy>=1.12.1 in /Users/userName/anaconda3/lib/python3.6/site-packages (from ont-albacore==2.1.10)
Collecting ont-fast5-api>=0.4.1 (from ont-albacore==2.1.10)
  Using cached ont_fast5_api-0.4.1-py2.py3-none-any.whl
Requirement already satisfied: six>=1.5 in /Users/userName/anaconda3/lib/python3.6/site-packages (from python-dateutil->ont-albacore==2.1.10)
Installing collected packages: progressbar33, ont-fast5-api, ont-albacore
Successfully installed ont-albacore-2.1.10 ont-fast5-api-0.4.1 progressbar33-2.4

At first sight, it looks like Albacore was successfully installed but if I run: read_fast5_basecaller.py --help

I get:

Traceback (most recent call last):
  File "/Users/userName/anaconda3/bin/read_fast5_basecaller.py", line 69, in <module>
    from albacore.input_utils import list_input_files
  File "/Users/userName/anaconda3/lib/python3.6/site-packages/albacore/input_utils.py", line 7, in <module>
    from albacore import log_utils
  File "/Users/userName/anaconda3/lib/python3.6/site-packages/albacore/log_utils.py", line 5, in <module>
    from albacore.pipeline_core import get_debug_level
ImportError: dlopen(/Users/userName/anaconda3/lib/python3.6/site-packages/albacore/pipeline_core.cpython-36m-darwin.so, 2): Library not loaded: /usr/local/opt/python3/Frameworks/Python.framework/Versions/3.6/Python
  Referenced from: /Users/userName/anaconda3/lib/python3.6/site-packages/albacore/pipeline_core.cpython-36m-darwin.so
  Reason: image not found

Is there a library missing?

  • 1
    $\begingroup$ Are you using a 32bit kernel by any chance? $\endgroup$
    – terdon
    Feb 22, 2018 at 14:53
  • 1
    $\begingroup$ Which python version? python --version You are using a wheel for python3.6 $\endgroup$ Feb 22, 2018 at 15:22
  • $\begingroup$ RELEASE_X86_64 x86_64, so 64 bit kernel $\endgroup$ Feb 22, 2018 at 18:06
  • $\begingroup$ and Python version 3.6 python --version Python 3.6.4 :: Anaconda, Inc. $\endgroup$ Feb 22, 2018 at 18:06
  • $\begingroup$ could you try python -m pip install ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl $\endgroup$ Feb 23, 2018 at 13:21

1 Answer 1


Not sure about conda as I don't use it, but I can highly recommend pipenv which is the python.org recommended package management system for python.

I have tested the following on my Mac and it worked like a dream

mkdir albacore && cd albacore
mv ../ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl .

# install pipenv if you don't have it
brew install pipenv  # or pip3 install pipenv

# the following will create a virtual environment and install albacore into it
pipenv install ont_albacore-2.1.10-cp36-cp36m-macosx_10_11_x86_64.whl

# activate the virtual environment
pipenv shell

read_fast5_basecaller.py -h

And that should bring up the albacore help menu and you're ready to go.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.