0
$\begingroup$

I tried to create galaxy local toolshed using planemo. I used command as follows,

  1. create virtual env

    virtualenv .venv; .venv/bin/activate
    
  2. Install planemo

    pip install planemo
    
  3. To configuring a shed account

    planemo config_init
    
  4. Create a repository

    planemo shed_init --name=seqtk_seq \
                      --owner=planemo \
                      --description=seqtk_seq \
                      --long_description="Tool that converts FASTQ 
                                          to FASTA files using seqtk" \
                      --category="Fastq Manipulation"
    planemo shed_create --shed_target local
    

This produces the following error:

Failed to include files for [{'source': '**'}]
Problem encountered executing action for one or more repositories.
(.venv) varuna@varuna-Inspiron-15-3567:~/git/galaxy_stable/planemo
$\endgroup$
5
  • 1
    $\begingroup$ Hi, could you paste the text of the error instead of screenshots? It might make it easier to read and help you. $\endgroup$
    – mgalardini
    Feb 27 '18 at 12:19
  • $\begingroup$ Failed to include files for [{'source': '**'}] Problem encountered executing action for one or more repositories. $\endgroup$ Mar 2 '18 at 8:25
  • $\begingroup$ Could not update local HTTPConnectionPool(host='localhost', port=9009): Max retries exceeded with url: /api/repositories?key=dc5c7cd5cf56a2f44aacf755109e63b9 (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f55542b7310>: Failed to establish a new connection: [Errno 111] Connection refused',)), 0 attempts left: $\endgroup$ Mar 2 '18 at 8:38
  • $\begingroup$ Try providing a project name planemo shed_create --shed_target local someProjectName. $\endgroup$
    – Devon Ryan
    Mar 6 '18 at 9:42
  • $\begingroup$ I created galaxy local toolshed editing the xml files inside galaxy folder and ran it using 9009 port. After run toolshed, I tried above mentioned command with project name. # planemo shed_create --shed_target local /home/varuna/git/galaxy_stable Got following error. "description required for automatic creation or update of shed metadata" $\endgroup$ Mar 8 '18 at 11:59
1
$\begingroup$

--shed_target local will only work if you're running a Galaxy toolshed on your local computer, since it's reading the .shed.yaml file you made with planemo shed_init and trying to create a repository with that name or a local (in this case) server. Planemo itself won't start a Galaxy toolshed, since it's fairly unusual for people to want to do testing involving creating local repositories. What you probably want to do instead is use planemo test instead. Once the planemo testing passes then use the various shed* commands to upload your wrapper to the toolshed or testtoolshed.

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.