2
$\begingroup$

I am wondering if anyone has tried aligning 1d^2 RNA-seq data. I am trying that on minimap2. It is giving me very low ~50% of mapped reads. it gives ~95% mapped reads for 1D.

I am using the following command for 1d and 1d^2:

minimap2 -ax splice -uf -k14 ref.fa direct-rna.fq > aln.sam

Update:

I also tried to play around the command using :

minimap2 -ax splice -k14 -a ref.fa direct-rna.fq > aln.sam
minimap2 -ax splice -ur -k14 ref.fa direct-rna.fq > aln.sam
minimap2 -ax splice -ub -k14 ref.fa direct-rna.fq > aln.sam

It did not work better.

FYI: I am trying to find answer for this from few days. I have posted this question on Biostars before. I did not get any response. Hence, I am trying to find the answer here.

Thank you in advance. I really appreciate any help.

$\endgroup$
4
  • 1
    $\begingroup$ Have you tried blatting/blasting a few of the non-aligning reads to check if they're okay? $\endgroup$ – Wouter De Coster Mar 2 '18 at 8:52
  • $\begingroup$ No, I have not. But it will be good exercise. I will do it. Thanks. $\endgroup$ – KVC_bioinfo Mar 2 '18 at 15:18
  • $\begingroup$ You might consider trying to put the blast results into MEGAN to see if there is contamination in your sample. Also, could you please update us with what your sample type is (organism, tissue, origin), and if you have an amplicon, gDNA, cDNA library? Here is the link to MEGAN: ab.inf.uni-tuebingen.de/software/megan6 $\endgroup$ – conchoecia Mar 5 '18 at 17:46
  • $\begingroup$ I have a similar problem (many unaligned reads). Did you find a solutioin? By any chance, did you compare minimap2 results with graphmap? $\endgroup$ – mjoppich Jun 30 '18 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.