1
$\begingroup$

I am trying to install Rostlab's PredictProtein in a Virtual Machine as detailed here https://rostlab.org/owiki/index.php/How_to_Run_The_PredictProtein_Machine_Image_with_VirtualBox:

  1. Download PredictProtein Machine Image to your local drive. You will need the Bio-Linux-based 'VMWARE/VMDK' format version.
    • Choose the Debian-based version in case you do not need a graphical user interface. This image is only half the size of the Bio-Linux-based image.
  2. Download a database image to your local drive. We recommend the 'raw' format version.
  3. Create New Virtual Machine: Machine -> New
  4. Name your virtual machine as 'PredictProtein'
  5. Choose Linux and Debian as operation system
  6. Locate and select the VMware .vmdk file as your boot disk
  7. Give at least 2GB of RAM to your virtual machine
  8. Click 'Finish'
  9. Boot your new virtual machine.
  10. If the message "The disk drive for /mnt/local-storage is not ready yet or not present" appears, press 's'.

The problem comes at this step:

  1. Open a terminal and enter:

    sudo mkfs.ext4 -F -m 0 -L local-storage /dev/sdb
    sudo mount -a
    sudo mkdir /mnt/local-storage/rostlab-data && cd /mnt/local-storage/rostlab-data
    sudo mount -a
    sudo mount /mnt/rostlab-data
    sudo tar -xvJf /mnt/rostlab-data/rostlab-data.txz
    sudo umount /mnt/rostlab-data && cd
    

When I run sudo mount /mnt/rostlab-data, I get:

mount: special device LABEL=rostlab-data does not exist

How should I proceed?

Additional notes -

The output for

cat /etc/fstab

is

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0   0
# / was on /dev/sda1 during installation
UUID=9a9418ff-48f9-421a-b25a-82161839351d / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=a96757f4-8cc7-410f-95ee-b5ae642eb9ed none swap sw  0       0

LABEL=local-storage /mnt/local-storage auto defaults,nofail 0   2
LABEL=rostlab-data /mnt/rostlab-data auto defaults,noauto,ro 0  0

/mnt/local-storage/rostlab-data /usr/share/rostlab-data none bind,nofail 0 0

The output for

blkid 

is

/dev/ramzswap0: TYPE="swap"
/dev/sda1: UUID="9a9418ff-48f9-421a-b25a-82161839351d" TYPE="ext4"
/dev/sda5: UUID="a96757f4-8cc7-410f-95ee-b5ae642eb9ed" TYPE="swap"
/dev/sdb: LABEL="local-storage" UUID="df841028-8dd1-4cd2-b1bb-6ae1f6887510" TYPE="ext4"
$\endgroup$
  • $\begingroup$ Sounds like they've misconfigured the image. Please edit your question and post the output of running cat /etc/fstab and blkid from the virtual machine. $\endgroup$ – terdon Mar 6 '18 at 11:12
0
$\begingroup$

It looks like the image you downloaded is missing the partition with the label rostlab-data. Your blkid output shows that you have the local-storage partition, but not the rostlab-data which is automatically added to your /etc/fstab.

I am afraid you'll have to contact the developers and let them know. Sounds like a bug.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.