3
$\begingroup$

I am running Cufflinks for transcriptome assembly using the .bam file generated by Hisat2. I tried both bam and sorted bam files

cufflinks --no-update-check -o ./ -p 15 accepted_hits.bam

it gives the following error:

Error: sort order of reads in BAMs must be the same

UPDATE: It is working fine now. It seems there were some issues with the reference file. The BAM files generated from Tophat2 also gave the same error. I downloaded the updated reference file and it worked great.

$\endgroup$
  • 2
    $\begingroup$ Maybe post some code so that we can follow what you're doing? $\endgroup$ – benn Apr 3 '18 at 11:00
  • $\begingroup$ Hello again, could you please add also the Hisat2 command? We are really trying to help, but to do that, we need more info. (do not hesitate to write there everything you tried) $\endgroup$ – Kamil S Jaron Apr 4 '18 at 8:38
  • $\begingroup$ Instead of an update the preferred method would be to create an answer and then accept it. $\endgroup$ – Bioathlete Apr 6 '18 at 18:31
6
$\begingroup$

Just add --dta-cufflinks to your Hisat2 command, so that the output alignment file provides the attributes needed by Cufflinks (XS flags). This should do the job.

From manual:

Report alignments tailored specifically for Cufflinks. In addition to what HISAT2 does with the above option (--dta), With this option, HISAT2 looks for novel splice sites with three signals (GT/AG, GC/AG, AT/AC), but all user-provided splice sites are used irrespective of their signals. HISAT2 produces an optional field, XS:A:[+-], for every spliced alignment.

$\endgroup$
  • 1
    $\begingroup$ If it was what you were looking for, please mark the answer as 'accepted' too. Future googlers will thank you ;) $\endgroup$ – aechchiki Apr 3 '18 at 15:45
  • $\begingroup$ Sure, I will do that. I am still running hisat2 with that option. $\endgroup$ – SBDK8219 Apr 3 '18 at 16:15
  • $\begingroup$ It is still not working !! $\endgroup$ – SBDK8219 Apr 4 '18 at 2:23
  • 2
    $\begingroup$ I need more detail. It worked for me. Please then edit the question wit exact command line, what you tried and possibly a minimal example to be run. Also, be sure you deleted previously generated files/directories from Cufflinks and Hisat2 before relaunching the clean pipeline. $\endgroup$ – aechchiki Apr 4 '18 at 5:00
  • 1
    $\begingroup$ Btw by 'more details' I meant also to paste in the question the command you used to generate the alignment file with Hisat2, also including the versions of both Hisat2 and Cufflinks that you are using. $\endgroup$ – aechchiki Apr 4 '18 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.