0
$\begingroup$

While running cellranger count using the following .slurm file:

#SBATCH -p standard
#SBATCH -A overall 
#SBATCH --time=48:00:00
#SBATCH --mail-type=end
#SBATCH --mail-user=nv4e@virginia.edu
#SBATCH --output=generate_count_%j.out
#SBATCH --error=generate_count_%j.err
#SBATCH --nodes=1
#SBATCH --ntasks=1
#SBATCH --cpus-per-task=20
#SBATCH --mem=120000


# Run driver program
FASTQS="/scratch/nv4e/kipnis/AHN3LLBGX5/outs/fastq_path/HN3LLBGX5"
TR="/scratch/nv4e/kipnis/refdata-cellranger-mm10-1.2.0"

cellranger count --id=17R_1 --transcriptome=${TR} --fastqs=${FASTQS} --sample=17R --expect-cells=2000

I got the error:

>2018-04-28 20:04:37 [runtime] (progress)        
ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMI
STRY.fork0.chnk0: Indexing genome...
2018-04-28 20:04:49 [runtime] (progress)        ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY.fork0.chnk0: Building transcriptome...
2018-04-28 20:04:58 [runtime] (progress)        ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY.fork0.chnk0: Building kmer index...
2018-04-28 20:05:25 [runtime] (progress)        ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY.fork0.chnk0: Mapping reads...
2018-04-28 20:05:28 [runtime] (chunks_complete) ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY
2018-04-28 20:05:28 [runtime] (run:local)       ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY.fork0.join
2018-04-28 20:05:31 [runtime] (join_complete)   ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.CHEMISTRY_DETECTOR.DETECT_CHEMISTRY

2018-04-28 20:05:34 [runtime] (ready)           ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.SETUP_CHUNKS
2018-04-28 20:05:37 [runtime] (split_complete)  ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.SETUP_CHUNKS
2018-04-28 20:05:37 [runtime] (run:local)       ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.SETUP_CHUNKS.fork0.chnk0.main
2018-04-28 20:05:40 [runtime] (failed)          
ID.17R_1.SC_RNA_COUNTER_CS.SC_RNA_COUNTER.SETUP_CHUNKS

>[error] The chemistry was unable to be automatically determined. This can happen if not enough reads originate from the given reference. Please verify your choice of reference or explicitly specify the chemistry via the --chemistry argument

What is going wrong here? How could I correct it?

$\endgroup$
2
  • 1
    $\begingroup$ You presumably aligned against the wrong reference transcriptome. $\endgroup$
    – Devon Ryan
    Apr 29 '18 at 6:08
  • $\begingroup$ It is very weird: the thing that the first time I ran it, it worked. Then, because we got bad results after running cellranger count ('bad' means biologically not what we want to see. It would mean that the biology was done in the wrong way), we transferred the raw data again, generated fastq files again and somehow now I am having this issue for the first replica, but not for the second one which ran successfully. I am wondering where in this chain of actions I did a mistake. Can it be that the data got corrupted while I was transferring it, however, fastq generation worked still? $\endgroup$ Apr 29 '18 at 22:55
1
$\begingroup$

The issue was that I supplied wrong indexes during fastq files generation, however, they were generated successfully, and only the next step failed with not that informative error.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.