0
$\begingroup$

I have a quick doubt on the output of the Genome Indexing, I have used the STAR program along with genome .fasta file and GFF file.

Genome size is 3GB, here is the file output

chrLength.txt
chrNameLength.txt
chrName.txt
chrStart.txt
genomeParameters.txt

I have another small Genome 60MB in size, I did the genome indexing, here is the file output

chrLength.txt
chrNameLength.txt
chrName.txt
chrStart.txt
exonGeTrInfo.tab
exonInfo.tab
geneInfo.tab
Genome
genomeParameters.txt
SA
SAindex
sjdbInfo.txt
sjdbList.fromGTF.out.tab
sjdbList.out.tab
transcriptInfo.tab

My point here is that, why I got the extra information for my small genome size, but I didn't get the same for the big size genome. I do apply the same procedure for the both.

here is the below information. Only difference I made for the large Genome size is (--sjdbOverhang 99 --genomeChrBinNbits 15) to reduce the memory, but the rest of things are same for small genome.

#!/bin/bash
NUM_THREADS=12
mkdir DB
STAR --runMode genomeGenerate --genomeDir DB \
    --runThreadN $NUM_THREADS \
    --genomeFastaFiles XL9_2.fa \
    --sjdbGTFfile XENLA_Frog.gtf+gff3 \
    --sjdbOverhang 99 \
    --genomeChrBinNbits 15

Could anyone give an idea, why there is different, I am new to this field, so I am wondering about the difference in this.

Thanks in advance.

Cheer San

$\endgroup$
  • $\begingroup$ The files missing in the case of the larger genome are the actual index itself - it doesn't look like STAR completed. Do you have STDOUT/STDERR from the runs? $\endgroup$ – sjcockell Jul 25 '18 at 13:20
  • $\begingroup$ Here is my below syntax, I use it for It #!/bin/bash module load star/2.5.0c NUM_THREADS=22 mkdir Sangv92db STAR --runMode genomeGenerate --genomeDir Sangv92db \ --runThreadN $NUM_THREADS \ --genomeFastaFiles /ifs/home/skm9/san/xlaevis/XL9_2.fa \ --sjdbGTFfile /ifs/home/skm9/san/xlaevis/XENLA_9.2_Xenbase.gff3 --sjdbOverhang 99 \ --genomeChrBinNbits 15, It run and gene the files out same like the above I mentioned. $\endgroup$ – San Jul 25 '18 at 14:43
  • $\begingroup$ here is the memory allocation I used for it, still not able to complete the indexing, ... qsub -pe threaded 4-20 -hard -l mem_free=400G -l h_vmem=560G -l mem_token=80G RunSTARIndex2.sh... $\endgroup$ – San Jul 25 '18 at 14:47
1
$\begingroup$

You didn't get extra information with the small genome, the index for the larger one just wasn't made. My guess is that you ran out of RAM. For mammalian sized genomes ensure you have at least 30GB of RAM, likely more like 60GB. Also, make sure to look for error messages.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ qsub -pe threaded 4 -hard -l mem_free=60G -l h_vmem=80G -l mem_token=60G RunSTARIndex.sh...do you think this much is enough, although one node has 128GB....hope this time it will....me running now...Thanks a million in advance... $\endgroup$ – San Jul 24 '18 at 21:36
  • $\begingroup$ Thanks for the information, I do run the same but it seems, its terminating and giving the same output files. ..this is what I tried in the last ...qsub -pe threaded 4-20 -hard -l mem_free=100G -l h_vmem=120G -l mem_token=60G RunSTARIndex2.sh....Each Node -128 RAM, is their other possible way to Index it? $\endgroup$ – San Jul 24 '18 at 22:50
  • $\begingroup$ Some genomes require gobs of memory. If you point me to the files you're trying to index I can try and do that for you. $\endgroup$ – Devon Ryan Jul 25 '18 at 6:44
  • $\begingroup$ Thanks a million Devon Ryan, I tried all possible way to increase memory like ....qsub -pe threaded 4-20 -hard -l mem_free=400G -l h_vmem=560G -l mem_token=80G RunSTARIndex2.sh, but still fail, I don't see any error message, its seems like it terminate on the half way...Could you let me know your email, My be I will email the same to you. $\endgroup$ – San Jul 25 '18 at 14:42
  • $\begingroup$ Genome Indexing for Xenopus leaves, v9.2, here is the link for the database xenbase.org/other/static/ftpDatafiles.jsp, Please let me know, if you can do the indexing for it, Let me know, how I can transfer the index file too, thanks a million in advance ... $\endgroup$ – San Jul 25 '18 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.