I am working on the Rivanna cluster that is of SLURM-type. Because of that I do not have write permissions and need to install the newest R version myself locally, and use it. For it to be successfully built from source, I needed to also build from source libcurl4-openssl-dev, so I downloaded tar.gz file from here:

https://packages.debian.org/ru/jessie/libcurl4-openssl-dev

and did:

mkdir build 
./configure --prefix=/scratch/nv4e/curl/build
make
make install

Then, in the same way I built from source R 3.5.1, the latest current version. It was compiled without any errors, but with some warnings. Then, I submitted the R script that uses SCnorm package:

https://bioconductor.org/packages/release/bioc/html/SCnorm.html

Inside of the script I am having:

source("https://bioconductor.org/biocLite.R")
biocLite("SCnorm")
biocLite("SingleCellExperiment")
library(SCnorm)
library(SingleCellExperiment) 

Of course, I am submitting it through .slurm file where I have the main command:

Rscript --vanilla scnorm.R

It fails, apparently because SCnorm requires RCurl, but it can not get one, even though in the log file it is trying to access it correctly:

enter image description here

The libcurl library was built from source in the /scratch/nv4e/curl/build folder. The only suspicion that I have here is that maybe its version is wrong and SCnorm needs another libcurl version? Any suggestions would be greatly appreciated.

Update

I tried reinstalling libcurl library from the official website, using the latest version:

https://curl.haxx.se/

But it did not fix the issue. I have also tried using libcurl from Anaconda but it gave the same error. So, neither 7.61.0 (latest), nor 7.29.0 (Anaconda), nor 7.38.0 (Debian link) are working.

This is a bug affecting the curl compile, it's been reported here and also here, I suggest trying to compile from the newer release of the libcurl source rather than the .deb you linked.

  • I tried reinstalling libcurl from here: curl.haxx.se, and it did not help. I see that the R is using the newly reinstalled version, and giving the same error. – Nikita Vlasenko Aug 10 at 20:03
  • Are you sure it's not hitting the old system version at compile time? – Matt Bashton Aug 13 at 9:18
  • Yes, sure. Cluster support fixed it. The issue was related to gcc version, but I am not completely sure what they did. – Nikita Vlasenko Aug 13 at 18:31
  • 1
    Glad it got fixed, although if you find out exactly it would be good to post and answer since this will help others with the same issue. – Matt Bashton Aug 13 at 19:57

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.