0
$\begingroup$

I'm trying to install Bioconductor packages with Microsoft R Open 3.5.0 seems to fail not sure what is the issue.

This is what I'm trying to do

source("https://bioconductor.org/biocLite.R")
biocLite("BiocInstaller")

But I keep getting an error about "curl" had non-zero exit. How can I install the packages of Bioconductor?

$\endgroup$
  • 2
    $\begingroup$ Please edit your question and clarify. Your first paragraph seems to be about installing R but the last one suggests you have already installed it. Please don't ask multiple questions in a single post, edit and ask one, specific and clear question. Thanks! $\endgroup$ – terdon Sep 11 '18 at 12:01
  • $\begingroup$ updated my question ..iim getting this "curl' non-zero exit which wanted to post the error but closed my terminal so lost the exact error message $\endgroup$ – krushnach Chandra Sep 11 '18 at 13:02
  • $\begingroup$ Then please run the command again and then add the error message to the your question. We can't help you solve an error if you don't show it. $\endgroup$ – terdon Sep 11 '18 at 13:56
2
$\begingroup$

I can't comment yet but from what you said it seems that you need to install additional libraries like the one you mentioned: "curl".

from the R terminal you should type:

install.packages("curl")

then R will install the package. Not sure if there are some other dependencies. If yes R will return you some error message in which there are some package names you need to install.

EDIT:

of course, after installing all the required packages you should be able to install biocLite too.

| improve this answer | |
$\endgroup$
  • $\begingroup$ cd /opt/microsoft/ropen/3.5.1/lib64/R/library/ inside the path i can see the curl so why still i get the error i'm not sure $\endgroup$ – krushnach Chandra Sep 11 '18 at 13:18
  • $\begingroup$ try loading the curl package from the R terminal and see if it actually works (library(curl)). Maybe some libraries are missing. I use linux and curl requires additional libraries that are not installed by R but are system's libraries. $\endgroup$ – gabt Sep 11 '18 at 13:24
  • $\begingroup$ yeah i did check the system level libraries as i can see using this "locate libcurl "so still not sure why the non-zero exit $\endgroup$ – krushnach Chandra Sep 11 '18 at 13:32
  • $\begingroup$ finally after some time it did work. $\endgroup$ – krushnach Chandra Sep 12 '18 at 7:16
  • 1
    $\begingroup$ sorry for not replying! if you solved the issue just post how you did it. This will help other people having the same problems! $\endgroup$ – gabt Sep 12 '18 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.