I am working on macOS High Sierra.

I am following the steps described here to lift an annotation over from one version of a genome to another. I am now just using the example genomes provided in the tutorial.

At this step:

time (doSameSpeciesLiftOver.pl -verbose=2 -buildDir=`pwd` \
      -ooc=`pwd`/${target}.ooc -fileServer=localhost -localTmp="/dev/shm" \
  -bigClusterHub=localhost -dbHost=localhost -workhorse=localhost \
  -target2Bit=`pwd`/${target}.2bit -targetSizes=`pwd`/${target}.chrom.sizes \
  -query2Bit=../${query}/${query}.2bit \
  -querySizes=../${query}/${query}.chrom.sizes ${target} ${query}) > do.log 2>&1

I get the following error in the do.log file:

Warning: Permanently added 'localhost' (ECDSA) to the list of known hosts.
username@localhost: Permission denied (publickey,password,keyboard-interactive).
HgStepManager: executing from step 'align' through step 'cleanup'.
HgStepManager: executing step 'align' Thu Nov  8 14:27:32 2018.
Using localhost, /Users/username/Documents/projects/main/output/software/liftover/data/genomes/GCA_000004515.3_Glycine_max_v2.0/GCA_000004515.3_Glycine_max_v2.0.2bit and ../GCF_000004515.3_V1.1/GCF_000004515.3_V1.1.2bit
align: localhost does not have /Users/username/Documents/projects/main/output/software/liftover/data/genomes/GCA_000004515.3_Glycine_max_v2.0/GCA_000004515.3_Glycine_max_v2.0.ooc -- if that is not the correct location, please run again with -ooc.

I think the main problem is here:

username@localhost: Permission denied (publickey,password,keyboard-interactive).

This post describes this issue. However:

  • I do not have this file: ~/.ssh/authorized_keys. My files in ~/.ssh are: github_rsa github_rsa.pub known_hosts. One of the lines of known_hosts is localhost. Does this presumably allow me to ssh to my own laptop? I still don't understand why I need to ssh in this script if it's run locally.
  • PasswordAuthentication yes is already in /etc/ssh/sshd_config
  • If I run the command without the time command, I still get the same error. I am not prompted to give a password.

Could anyone help me overcome this problem, please?

up vote 2 down vote accepted

You need to setup ssh keys. All the commands in the script are going to use ssh to run the commands. Note the tips here of how to setup ssh keys:

http://genomewiki.ucsc.edu/index.php/Parasol_job_control_system#SSH_keysssh key setup

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.