I am trying to basecall data produced by the MinION using the SQK-LSK109 kit and FLO-MIN106 flowcell via the command-line. My version of albacore is the latest (v2.3.4). I tried running using the following command-line (the name of the sequencing run and fast5s are different and are default from machine output):

python3.6 /home/dkennetz/.local/bin/read_fast5_basecaller.py -i ./seqrun/fast5/ -t 1 -s ./good_reads/ -f FLO-MIN106 -k SQK-LSK109 -r -o fastq

-t 1 is just for this test. It is running and finishing almost instantly with 0 errors but outputting no reads. I have previously run this same command-line using the SQK-LSK108 kit and had no problems.

I then went on to validate the fast5s using the h5_validate tool:

python3.6 /home/dkennetz/.local/bin/h5_validate /home/dkennetz/.local/lib/python3.6/site-packages/h5_validator/schemas/single_read_fast5.yaml seqrun/fast5/0/seqrun.fast5 -v

The output from this is:

    Matcher <'UniqueGlobalKey', type=group match_type=exact count=
{'minimum_count': 1, 'maximum_count': 1}> was not satisfied after matching <HDF5 file "seqrun.fast5" (mode r)>

Error at /:

Matcher <'PreviousReadInfo', type=group match_type=exact count=
{'minimum_count': 1, 'maximum_count': 1}> was not satisfied after matching <HDF5 file "seqrun.fast5" (mode r)>

I read on the community page that this may be because the header is missing some relevant meta-data information? Any help on how to fix this would be greatly appreciated!

This is cross-posted on the community page for ONT here:



1 Answer 1


I believe you have multiread fast5 files, as generated by recent versions of MinKNOW. A conversion script is available to convert these to the older, one-read one-file format. AFAIK Albacore is being deprecated and no version will be made supporting the multiread fast5 files, as Albacore is being replaced by Guppy.

The command line to convert from multi read fast5s to single read fast5s is as follows:

$multi_to_single_fast5 -i /path/to/fast5/ -s /path/to/save/output/
  • 2
    $\begingroup$ Hi Wouter, thanks for the answer! This worked as expected. To clear any ambiguity, I edited to add the command-line for future viewers. You can choose to accept or not, I just thought it added clarity! I appreciate the link. $\endgroup$
    – d_kennetz
    Jan 23, 2019 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.