2
$\begingroup$

I am very new to bioinformatics and Linux and am trying to run psipred locally on Ubuntu 18.04 but cannot get PSI-BLAST to work. I have downloaded BLAST legacy version 2.2.26 and unpacked it, uniref90 database and psipred version 4.01

I installed psipred according to instructions:

cd psipred/src
make
make install

And this seems to work fine

I used the following code to create a database, which proceeded without errors:

makeblastdb -in uniref90.fasta -dbtype prot -out uniref90

In runpsipred I changed the directories:

# The name of the BLAST data bank
set dbname = /home/hilda/uniref90

# Where the NCBI programs have been installed
set ncbidir = /home/hilda/blast/bin

# Where the PSIPRED V4 programs have been installed
set execdir = ./bin

# Where the PSIPRED V4 data files have been installed
set datadir = ./data

I then try to run psipred:

tsch ./runpsipred example/example.fasta

And get the error

Running PSI-BLAST with sequence example/example.fasta ...
FATAL: Error whilst running blastpgp - script terminated!

I am not sure how to solve this as I do not understand what is going wrong. As I said I am new to Linux. I use the command tsch to run psipred (otherwise I get the error "command not found"), but not to install the database, could this be a problem? Or have I missed something in the setup process? Running psipred does create a copy of the example.fasta in the psipred folder named psitmp4286007f010.fasta, but that is all that seems to happen.

I would greatly appreciate any suggestions on how to make it work!

Edit: I tried to run with BLAST+ (which seemed to work without tsch) and get the following error:

BLAST Database error: No alias or index file found for protein database [/home/hilda/uniref90] in search path [/home/hilda/psipred::]

I have also tried setting dbname to home/hilda/uniref90/uniref90 and got the same results. there is a uniref90.pal file in the uniref90 directory, which I understand is the alias file? Other forum answers seem to use pfilt to index (?) the database, but there is no pfilt in my psipred directory. Any ideas how to fix the problem?

$\endgroup$
4
  • $\begingroup$ Welcome to the site Hilda. I think that the supported version is now blast+ or something alike. Is there any special reason why you need the legacy 2.2.26? It will get easier to get support and trouble shot the problems if you install the supported version. In addition, it could be that the legacy version does not work with Ubuntu 18.04... $\endgroup$
    – llrs
    Feb 13 '19 at 14:02
  • $\begingroup$ I use tcsh, but I would make a new attempt using bash. $\endgroup$
    – M__
    Feb 14 '19 at 1:20
  • $\begingroup$ I picked the BLAST version based on what seemed to be the most commonly used in forums and similar questions, and that I got the impression that psipred preferes legacy to +. Will definitely try downloading and running BLAST+ instead. Thank you! $\endgroup$
    – Hilda
    Feb 14 '19 at 8:29
  • $\begingroup$ I'm having the exact same problem. I'm using BLAST+ though and runpsipredplus script. Did you manage to make it run and how did you do it? $\endgroup$ Feb 1 at 2:20
4
$\begingroup$

This error could be due to the fact that you are using legacy blast, have you tried using BLAST+ instead? If you wish to use PSIPRED with BLAST+, then use the runpsipredplus script here, rather than the normal runpsipred script.

$\endgroup$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.