3
$\begingroup$

I get the following error when I try to load a .chip file to GSEA software. What is the problem?

---- Full Error Message ----
There were errors: ERROR(S) #:1
Parsing trouble
java.lang.NumberFormatException: ...

---- Stack Trace ----
# of exceptions: 1
------For input string: "YBL028C"------
java.lang.NumberFormatException: For input string: "YBL028C"
    at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
    at sun.misc.FloatingDecimal.parseFloat(Unknown Source)
    at java.lang.Float.parseFloat(Unknown Source)
    at edu.mit.broad.genome.parsers.TxtDatasetParser._parseNoDesc(TxtDatasetParser.java:169)
    at edu.mit.broad.genome.parsers.TxtDatasetParser.parse(TxtDatasetParser.java:131)
    at edu.mit.broad.genome.parsers.TxtDatasetParser.parse(TxtDatasetParser.java:87)
    at edu.mit.broad.genome.parsers.ParserFactory.readDatasetTXT(ParserFactory.java:202)
    at edu.mit.broad.genome.parsers.ParserFactory.read(ParserFactory.java:749)
    at edu.mit.broad.genome.parsers.ParserFactory.read(ParserFactory.java:726)
    at edu.mit.broad.genome.parsers.ParserWorker.doInBackground(ParserWorker.java:52)
    at javax.swing.SwingWorker$1.call(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at javax.swing.SwingWorker.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

Edit:

Here is the first few lines of the table I am using

I am also using GSEA 3.0. What does not make sense is the other files have the right extensions and are not getting this error, but only this file is failing to upload.


https://www.gsea-msigdb.org/gsea/index.jsp

"Gene Set Enrichment Analysis (GSEA) is a computational method that determines whether an a priori defined set of genes shows statistically significant, concordant differences between two biological states (e.g. phenotypes). "

$\endgroup$
4
  • 2
    $\begingroup$ Hi there, would you mind sharing a bit more details? What have you tried to resolve your problem? DO you think it's a problem of installation or the file? Note also that you can edit your question. $\endgroup$ Mar 15, 2019 at 8:49
  • $\begingroup$ Also perhaps it could be useful to know which version of GSEA are using and how are the first lines from the file (or those around YBL028C ) $\endgroup$
    – llrs
    Mar 15, 2019 at 9:39
  • 2
    $\begingroup$ Please show us an example of the file you are trying to load. It is complaining about YBL028C. That looks like a gene/protein name, but the tool is trying to read it as a number. So where do you have YBL028C in your data? What is a .chip file? $\endgroup$
    – terdon
    Mar 15, 2019 at 11:09
  • 1
    $\begingroup$ did you already solve the problem? I also came across the same error when uploading a similar .chip file. $\endgroup$
    – qi wu
    Apr 6, 2021 at 8:09

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.