2
$\begingroup$

I am working on a GNU/Linux machine. I have installed BUSCO using conda. I have downloaded the nematode dataset nematoda_odb9.tar.gzhere. I downloaded the reference sequence of C. elegans from Ensembl. I then ran busco using the following command:

run_busco --in Caenorhabditis_elegans.WBcel235.dna.toplevel.fa --cpu 1 --out busco --lineage_path ./nematoda_odb9/ --mode genome --force > busco.o 2> busco.e

tblastn seems to have run properly. run_busco/blast_output/tblastn_busco.tsv contains lots of hits for many of the buscos.

However, I have 982 "Missing BUSCOs".

The file that contains logs and errors related to augustus (run_busco/augustus_output/augustus.log) contains:

Will create parameters for a EUKARYOTIC species!
creating directory ...anaconda/envs/busco3_0_2/config/species/BUSCO_busco_1395218643/ ...
creating ...anaconda/envs/busco3_0_2/config/species/BUSCO_busco_1395218643/BUSCO_busco_1395218643_parameters.cfg ...
creating ...anaconda/envs/busco3_0_2/config/species/BUSCO_busco_1395218643/BUSCO_busco_1395218643_weightmatrix.txt ...
creating ...anaconda/envs/busco3_0_2/config/species/BUSCO_busco_1395218643/BUSCO_busco_1395218643_metapars.cfg ...
The necessary files for training BUSCO_busco_1395218643 have been created.
Now, either run etraining or optimize_parameters.pl with --species=BUSCO_busco_1395218643.
etraining quickly estimates the parameters from a file with training genes.
optimize_augustus.pl alternates running etraining and augustus to find optimal metaparameters.

It does not seem to contain any errors.

I have the following error:

Failed to open sequence file run_busco/augustus_output/extracted_proteins/EOG091H07ZC.faa.1 In fact, the folder run_busco/augustus_output/extracted_proteins/ is empty.

Anyone would know why I have no extracted proteins?

$\endgroup$
2
$\begingroup$

Most likely your Augustus installation is not functioning properly. Did you install Augustus from source or using conda? I believe the conda version of Augustus is known to have some issues.

Something worth trying: Running a complete busco install in a VM. This image has all dependencies installed and properly configured.

$\endgroup$
4
  • 1
    $\begingroup$ It was installed via conda, the log output clearly shows the Anaconda being accessed for busco installation. Personally I'm surprised because Anaconda programs are very reliable, but that might just be the core installation (at least for Mac OSX). Anyway its good advice to try a direct installation. Could you please point out what "some issues" might be? $\endgroup$ – M__ May 10 '19 at 13:32
  • $\begingroup$ BUSCO worked with this Docker image: hub.docker.com/r/comics/busco I'll try again using the conda installation and point towards some issues but for the moment, I am happy I could run it in a Docker container. $\endgroup$ – charlesdarwin May 10 '19 at 20:57
  • 1
    $\begingroup$ @MichaelG. you are right that is quite reliable in general. Augustus however, is quite tedious in it's installation (e.g. the location of the config file and the location of it's species training-sets). For example, the manual of BRAKER(the automated gene annotation program) states: "Problems have been reported from users that tried to run BRAKER with AUGUSTUS releases maintained by third parties, i.e. Bioconda". They therefore recommend to install Augustus as distributed by the original developers $\endgroup$ – Jvstonebridge May 11 '19 at 17:00
  • $\begingroup$ @charlesdarwin That's good to hear! Most likely the person that build that docker container did a correct installation of Augustus for you :) $\endgroup$ – Jvstonebridge May 11 '19 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.