1
$\begingroup$

bcl2fastq is a program that converts Illumina run output from .bcl to fastq. I'm having difficulties installing the software I downloaded from Illumina on my Ubuntu 18.04. I've followed their installation manual, but the software is not building when I enter the command "make". I receive the error message... "make: *** No targets specified and no makefile found. Stop. Has anyone had similar experience? Is there another software that will install easier on Ubuntu?

Software: https://support.illumina.com/downloads/bcl2fastq-conversion-software-v2-20.html

Manual: https://support.illumina.com/content/dam/illumina-support/documents/documentation/software_documentation/bcl2fastq/bcl2fastq2-v2-20-software-guide-15051736-03.pdf

Steps followed:

export TMP=/tmp
export SOURCE=${TMP}/bcl2fastq
export BUILD=${TMP}/bcl2fastq2-v2.20.0-build
export INSTALL_DIR=/usr/local/bcl2fastq2-v2.20.0

cd ${TMP}
tar -xvzf bcl2fastq2-v2.20.0.499-Source.tar.gz

mkdir ${BUILD}
cd ${BUILD}
chmod ugo+x ${SOURCE}/src/configure
chmod ugo+x ${SOURCE}/src/cmake/bootstrap/installCmake.sh
${SOURCE}/src/configure --prefix=${INSTALL_DIR}

cd ${BUILD}
make

The final command is supposed to be make install, but the configure step fails with:

[ . . . ]
-- Configuring incomplete, errors occurred! 
Couldn't configure the project: 
/tmp/bcl2fastq2-v2.20.0-build/bootstrap_cmake/bin/cmake -H'/tmp/bcl2fastq/src' -B'/tmp/bcl2fastq2-v2.20.0-build' -G'Unix Makefiles' -DBCL2FASTQ_NAME_SHORT:STRING="bcl2fastq" -DBCL2FASTQ_NAME_LONG:STRING="BCL to FASTQ file converter" -DBCL2FASTQ_COPYRIGHT:STRING="Copyright (c) 2007-2017 Illumina, Inc." -DBCL2FASTQ_VERSION_MAJOR:STRING="2" -DBCL2FASTQ_VERSION_MINOR:STRING="20" -DBCL2FASTQ_VERSION_PATCH:STRING="0" -DBCL2FASTQ_VERSION_BUILD:STRING="422" -DBCL2FASTQ_VERSION:STRING="2.20.0.422" -DBCL2FASTQ_SOURCE_DIR:STRING="/tmp/bcl2fastq/src" -DBCL2FASTQ_PREFIX:PATH="/usr/local/bcl2fastq2-v2.20.0" -DBCL2FASTQ_EXEC_PREFIX:PATH="" -DCMAKE_INSTALL_PREFIX:PATH="/usr/local/bcl2fastq2-v2.20.0" -DBCL2FASTQ_BINDIR:PATH="" -DBCL2FASTQ_LIBDIR:PATH="" -DBCL2FASTQ_LIBEXECDIR:PATH="" -DBCL2FASTQ_INCLUDEDIR:PATH="" -DBCL2FASTQ_DATADIR:PATH="" -DBCL2FASTQ_DOCDIR:PATH="" -DBCL2FASTQ_MANDIR:PATH="" -DCMAKE_BUILD_TYPE:STRING="RelWithDebInfo" -DCMAKE_PARALLEL:STRING="1" 
Moving CMakeCache.txt to CMakeCache.txt.removed 
$\endgroup$
13
  • $\begingroup$ Please edit your question and add: i) the URL of the software you downloaded; ii) the exactly commands you have run. Are you running make from the directory where you have run .configure? Did you run configure? $\endgroup$
    – terdon
    Jun 6 '19 at 16:24
  • $\begingroup$ Thanks for the edit, that's clearer! Now, some of those commands should have given an error message, did they? Especially the ${SOURCE}/src/configure --prefix=${INSTALL_DIR}, did that finish successfully? And what happens if you now run cd /tmp/bcl2fastq2-v2.20.0-build; make? Have you installed the build-essentials (sudo apt install build-essentials) package on Ubuntu? $\endgroup$
    – terdon
    Jun 6 '19 at 17:58
  • $\begingroup$ No errors displayed when I ran the commands. I haven't been able to install the build-essentials... I get the message "Unable to locate package build-essentials. The message I get when I run "make" is something about not having a target. $\endgroup$ Jun 6 '19 at 18:17
  • 2
    $\begingroup$ Please edit your question and add all this information. You can use the formatting tools to format your commands and their output as code. Comments are hard to read, easy to miss and can be deleted without warning. $\endgroup$
    – terdon
    Jun 6 '19 at 22:50
  • 2
    $\begingroup$ I suggest you install it via the RPM, this is an incredibly annoying package to compile yourself (this is unfortunately common with software from Illumina). $\endgroup$
    – Devon Ryan
    Jun 7 '19 at 9:40
4
$\begingroup$

Install it with conda.

conda install -c dranew bcl2fastq
$\endgroup$
2
  • $\begingroup$ Hope you don't get sued by Illumina for illegal distribution of their software... $\endgroup$
    – Devon Ryan
    Jun 25 '20 at 13:34
  • $\begingroup$ ... need to preferably install Anaconda3/minicoda . $\endgroup$
    – M__
    Jun 25 '20 at 15:19
0
$\begingroup$

Where are you running the software? In general and especially for servers and high performance clusters I would recommend to use a module system like Lmod in conjunction with EasyBuild, which contains configs for bcl2fastq2 that take care of the installation. A module system allows you to use different versions and to keep your environment clean among other benefits.

$\endgroup$
1
  • $\begingroup$ The OP is running the software on their own Ubuntu machine, I'm not sure EasyBuild would be appropriate in context. $\endgroup$
    – M__
    Jun 22 '20 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.