2
$\begingroup$

I'm trying to run Repeatmasker in Linux on the command line with:

./RepeatMasker -species human -alu -gff -dir /mnt/lustre/users/Analysis/RepeatMaskerOutput /mnt/lustre/users/Software/STAR/bin/Linux_x86_64/HRG_Newest_and_Annotation/GCA_000001405.28_GRCh38.p13_genomic.fna

but I am getting this error:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB.utf8",
        LC_ALL = "",
        LC_CTYPE = "en_GB.utf8",
        LANG = "en_GB.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
RepeatMasker version open-4.0.9
TRF program not configured! This version of RepeatMasker requires a
local installatoin of TRF.  Please visit:
               http://tandem.bu.edu/trf/trf.html
to obtain the current version.  Once installed please re-run the
RepeatMasker configure script to setup RepeatMasker to use the new
installation. at ./RepeatMasker line 442.

I have downloaded rmBlast and the latest TRF file. I have put the TRF file in my Users/username/bin PATH folder and used chmod a+x (and chmod 755) on it. I then changed my LD_LIBRARY_PATH using export to my glibc directory.

After this I used perl ./configure and directed the program to the PATH folder where the TRF file was. It gave a series of the same error messages as above but was 'successful' as shown here:


[user@nodec23() RepeatMasker]$ perl ./configure
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
RepeatMasker Configuration Program



**TRF PROGRAM**

  This is the full path to the TRF program.
 This is now used by RepeatMasker to mask simple repeats.











Enter path  [ /mnt/lustre/users/Software/RepeatMasker/RepeatMasker/TRF.pm ]:



Add a Search Engine:
   1. Crossmatch - Phrap             [ Configured ]
   2. RMBlast - Improved NCBI Blast  [ Configured, Default ]
   3. HMMER3.1 & DFAM                [ Un-configured ]
   4. ABBlast/WUBlast                [ Un-configured ]

   5. Done


Enter Selection: 5
 -- Setting perl interpreter...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Congratulations!  RepeatMasker is now ready to use.
The program is installed with a the following repeat libraries:
  Dfam database version Dfam_3.0
  RepeatMasker Combined Database: Dfam_3.0
Further documentation on the program may be found here:
  /mnt/lustre/users/Software/RepeatMasker/RepeatMasker/repeatmasker.help

I'm at a loss of what to do next. I have googled and tried changing each of the locale settings with export to the following:

  • en_GB
  • en_US.utf8
  • en_GB:2000
  • en_GB.utf8

but none have changed the error.

I am running a Windows 10 machine and using PuTTY to connect to an HPC which uses a Linux environment.

Locale settings are as follows:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_GB
LC_CTYPE="en_GB"
LC_NUMERIC="en_GB"
LC_TIME="en_GB"
LC_COLLATE="en_GB"
LC_MONETARY="en_GB"
LC_MESSAGES="en_GB"
LC_PAPER="en_GB"
LC_NAME="en_GB"
LC_ADDRESS="en_GB"
LC_TELEPHONE="en_GB"
LC_MEASUREMENT="en_GB"
LC_IDENTIFICATION="en_GB"
LC_ALL=

Also please note that I do not have administrator access.

Typing 'perl -v' gives the following:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_GB"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

Copyright 1987-2009, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

Typing "LC_ALL=C perl ./configure" and going throught the configurations leads to the same outcome but without the perl errors:

Enter Selection: 5
 -- Setting perl interpreter...

Congratulations!  RepeatMasker is now ready to use.
The program is installed with a the following repeat libraries:
  Dfam database version Dfam_3.0
  RepeatMasker Combined Database: Dfam_3.0
Further documentation on the program may be found here:
  /mnt/lustre/users/k1894998/Software/RepeatMasker/RepeatMasker/repeatmasker.help

However, the error remains when trying to run Repeatmasker.

Many thanks for any help provided!

$\endgroup$
  • 1
    $\begingroup$ Please don't post images of text. They make the post slower to load (important for slow connections), but more importantly images are not searchable. Instead, just copy/paste the text directly into your question and use the formatting tools to format it as code. $\endgroup$ – terdon Jul 1 at 8:44
  • 1
    $\begingroup$ Also, what operating system are you using? You mentioned a Users directory, are you on macOS? What command gives the error? Does it help if you run LC_ALL=C perl ./configure? $\endgroup$ – terdon Jul 1 at 8:47
  • 1
    $\begingroup$ if you type "perl -v" ... what happens? $\endgroup$ – Michael G. Jul 1 at 11:22
  • $\begingroup$ Note that the thing about locales is just a warning. It is annoying, but this should not cause the program to fail. $\endgroup$ – bli Jul 1 at 13:31
  • $\begingroup$ Thanks very much for your comments. I've updated the post to answer your questions. Still no luck getting it to work, unfortunately. $\endgroup$ – RNAdey Jul 1 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.