0
$\begingroup$

How do I solve the problem of loading the bioconductor Chipseeker package? I have installed in the following way and I having an error while loading it and I do not know why.

BiocManager::install("ChIPseeker")
BiocManager::install("TxDb.Hsapiens.UCSC.hg38.knownGene")
BiocManager::install("TxDb.Hsapiens.UCSC.hg19.knownGene")

library(ChIPseeker) # produces and error

Error: package or namespace load failed for 'ChIPseeker': 
  'TxDb.Hsapiens.UCSC.hg19.knownGene' is not exported from 'namespace: TxDb.Hsapiens.UCSC.hg19.knownGene'

Thank you in advance for any help on how to go about this.

session info:

R version 3.5.1 (2018-07-02)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

locale:
[1] LC_COLLATE=German_Germany.1252  LC_CTYPE=German_Germany.1252    LC_MONETARY=German_Germany.1252
[4] LC_NUMERIC=C                    LC_TIME=German_Germany.1252    

attached base packages:
[1] stats4    parallel  stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
 [1] BiocInstaller_1.32.1                    TxDb.Hsapiens.UCSC.hg19.knownGene_3.2.2
 [3] TxDb.Hsapiens.UCSC.hg38.knownGene_3.4.0 GenomicFeatures_1.34.8                 
 [5] AnnotationDbi_1.44.0                    GenomicRanges_1.34.0                   
 [7] GenomeInfoDb_1.18.2                     IRanges_2.16.0                         
 [9] S4Vectors_0.20.1                        cellrangerRkit_1.1.0                   
[11] Rmisc_1.5                               plyr_1.8.4                             
[13] lattice_0.20-35                         bit64_0.9-7                            
[15] bit_1.1-14                              ggplot2_3.1.1                          
[17] RColorBrewer_1.1-2                      Biobase_2.42.0                         
[19] BiocGenerics_0.28.0                     Matrix_1.2-14                          

loaded via a namespace (and not attached):
Error in x[["Version"]] : subscript out of bounds
In addition: Warning message:
In FUN(X[[i]], ...) : DESCRIPTION von Paket 'digest' fehlt oder zerstört
$\endgroup$
1
  • $\begingroup$ There might be a problem with your current R session if sessionInfo() gives you an error. Try restarting the R session (if you're using RStudio) or just exiting and starting a new R session (if you're on the command line). $\endgroup$
    – Ram RS
    Jul 8 '19 at 13:37
1
$\begingroup$

Simple, use the latest version of R and Bioconductor, now on version 3.6.1 and Bioconductor 3.9. Those are the versions that are supported. If you can't upgrade R, check that BiocManager::valid() is true, you might have ended in some inconsistency between Bioconductor versions.

Looking at your sessionInfo, you seem to have some problems with the installed libraries, check and correct those too if possible

$\endgroup$
2
  • $\begingroup$ @IIrs: BiocManager::valid() gives the Warning message: 10 packages out-of-date; 1 packages too new. How can I know the package which is too new? $\endgroup$
    – Charles
    Jul 8 '19 at 15:42
  • $\begingroup$ It also printed some more messages. Please edit the original question and post the full comment. If it didn't (I don't know how that could be) use BiocManager::install() (without any package), it should update the out-of-date packages. But the problem might be that this too-new is the one you have problems with. Store the result of a <- BiocManager::valid() and explore the a$toonew(or something alike). $\endgroup$
    – llrs
    Jul 8 '19 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.