1
$\begingroup$

I'm trying to download the 1000 Genomes (phase 3) through FTP, but it's taking ages. I saw the documentation about using Aspera (fasp protocol), but the instructions don't work: ERR [ascp] SSH authentication failed. Eg:

ascp -i /home/ibmuser/.aspera/connect/etc/asperaweb_id_dsa.putty -Tr -Q -l 100M \
     -P33001 -L- fasp-g1k@fasp.1000genomes.ebi.ac.uk:vol1/ftp/release/20130502/ALL.chr1.phase3_shapeit2_mvncall_integrated_v5a.20130502.genotypes.vcf.gz.tbi ./

Via Aspera Desktop client I got: SSH_MSG_DISCONNECT: 2 Too many authentication failures

Thanks!

$\endgroup$
0
$\begingroup$

You are using the command for older versions. In the page you link to, they give two commands, one for the newer and one for the older versions of aspera. You are using the one for the older. The only difference is the keyfile, but what you want is:

ascp -i /home/ibmuser/.aspera/connect/etc/asperaweb_id_dsa.openssh -Tr -Q -l 100M \
 -P33001 -L- fasp-g1k@fasp.1000genomes.ebi.ac.uk:vol1/ftp/release/20130502/ALL.chr1.phase3_shapeit2_mvncall_integrated_v5a.20130502.genotypes.vcf.gz.tbi ./

At least, I just tried this a second ago with the aspera bundle I downloaded today and that's the command that worked: asperaweb_id_dsa.openssh and not asperaweb_id_dsa.putty.

$\endgroup$
  • $\begingroup$ Yep! I was getting back here to post the answer as I realised the same lol. Accepted your answer in this case. Thanks! :) $\endgroup$ – Bruno Ambrozio Nov 8 at 10:28
  • $\begingroup$ Btw - I've created a script to download everything: github.com/bambrozio/bioinformatics/tree/master/utils $\endgroup$ – Bruno Ambrozio Nov 8 at 10:28
  • $\begingroup$ @BrunoAmbrozio nice! But note that you forgot the sex chromosomes. And also the various alt ones if any are present. $\endgroup$ – terdon Nov 8 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.