1
$\begingroup$

I have some highly contaminated ancient DNA sequences. I have adapter removed and collapsed these and run them through Kraken2. The Kraken reports show multiple levels of taxa with good numbers of reads in each.

However, when I run Bracken - I keep getting an error saying it can't find any reads.

Error: no reads found. Please check your Kraken report

I have tried adjusting the taxonomic level (all the way up to Phylum) and get the same result. I have tried using different databases to run the Kraken analysis through and updating both packages.

Any ideas what could be going wrong?

Update:

Here's the head of one of the report files:

enter image description here

I am also using the latest version of Bracken downloaded via Bioconda. My command to run Bracken is via a bash script:

#SBATCH --partition=day
#SBATCH --output=slurm_bracken_job%J.out
#SBATCH --mem-per-cpu=10G
#SBATCH --cpus-per-task=32

# we load kraken2 and bracken into our environment:
ml kraken2
ml bracken

NAME=$1

srun bracken -d /workspaces/groups/database/nt-taxonomy-2021-02-04_braken/ -i ${NAME}.kreport -o ${NAME}.bracken -r 75 -l S

This is then run using:

for i in $(ls -1 ./*.report | sed 's/.report//'); do sbatch Test_Kraken.sh "$i"; done
$\endgroup$
7
  • 2
    $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Jul 14, 2023 at 15:21
  • 1
    $\begingroup$ It would be helpful if you could give details about your Bracken installation, the structure of your Kraken2 reports (what do the first few lines look like?), and the exact command you ran that threw the error $\endgroup$
    – acvill
    Jul 14, 2023 at 16:06
  • 1
    $\begingroup$ I've updated the main post - I have used a couple of different databases as was suggested in a github post that had the same problem but to no avail. $\endgroup$ Jul 14, 2023 at 16:50
  • $\begingroup$ Thanks thats much better. My advice is one working first without the bash for loop. Bracken works, what I think is somethings not right in the run command. $\endgroup$
    – M__
    Jul 14, 2023 at 16:51
  • $\begingroup$ I have just tried running a basic bracken -d /workspaces/groups/database/nt-taxonomy-2021-02-04_braken/ -i Sample_1.collapsed.report -o Sample_!.report.bracken -r 75 -l S and still the same error $\endgroup$ Jul 14, 2023 at 17:14

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.